no init script

Discussion in 'Installation/Configuration' started by Steffan, Nov 1, 2021.

  1. Steffan

    Steffan Member

    After updating to the latest version (centos 8)
    im suddenly getting emails with:

    01.11.2021-10:11 - WARNING - We got no init command, restart or reload
    of php-fpm service aborted.

    01.11.2021-10:11 - WARNING - No init script, we quit here.

    I'm running a server with multi php setup. php 7.1, 7.3 and default php 7.4
    Code:
    php-fpm.service                    loaded active running The PHP FastCGI Process Manager
    php71-php-fpm.service              loaded active running The PHP FastCGI Process Manager
    php73-php-fpm.service              loaded active running The PHP FastCGI Process Manager
    
    in ssh i can reload all3 without any errors.
    Any idees ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the settings of the additional php versions, you have probably something wrong in the init script field there. Correct would be 'php-fpm' and 'php71-php-fpm' and 'php73-php-fpm' in your case if the server is using systems (which should be the case on CentOS 8).
     
  3. Steffan

    Steffan Member

    yes those settings are correct.
    This server is running for more then a year with those settings without any problems.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. Steffan

    Steffan Member

    Code:
    01.11.2021-14:03 - DEBUG - Trying to use Systemd to restart service
    01.11.2021-14:03 - DEBUG - safe_exec cmd: systemctl is-enabled 'php73-php-fpm' 2>&1 - return code: 1
    01.11.2021-14:03 - DEBUG - Failed to use Systemd to restart service php73-php-fpm, we try init script instead.
    01.11.2021-14:03 - DEBUG - Using init script to restart service
    01.11.2021-14:03 - WARNING - No init script, we quit here.
    01.11.2021-14:03 - DEBUG - Restarting php-fpm:
    01.11.2021-14:03 - WARNING - We got no init command, restart or reload of php-fpm service aborted.
    Code:
    01.11.2021-14:03 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    01.11.2021-14:03 - DEBUG - Found 1 changes, starting update process.
    01.11.2021-14:03 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    01.11.2021-14:03 - DEBUG - Calling function 'update' from plugin 'apache2_plugin' raised by event 'web_domain_update'.
    01.11.2021-14:03 - DEBUG - Info: Apache is chrooted.
    01.11.2021-14:03 - DEBUG - safe_exec cmd: chattr -i '/var/www/clients/client170/web385' - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client170/web385' - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: df -T '/var/www/clients/client170/web385'|awk 'END{print $2,$NF}' - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'setquota' 2> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: setquota -u 'web385' '0' '0' 0 0 -a &> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: setquota -T -u 'web385' 604800 604800 -a &> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: chattr +i '/var/www/clients/client170/web385' - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 1
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apachectl' 2> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 1
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apachectl' 2> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - Enable SSL for: duo-care.nl
    01.11.2021-14:03 - DEBUG - Writing the vhost file: /etc/httpd/conf/sites-available/duo-care.nl.vhost
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apache2ctl' 2> /dev/null - return code: 1
    01.11.2021-14:03 - DEBUG - safe_exec cmd: which 'apachectl' 2> /dev/null - return code: 0
    01.11.2021-14:03 - DEBUG - Writing the PHP-FPM config file: /etc/php-fpm.d/web385.conf
    01.11.2021-14:03 - DEBUG - Removed PHP-FPM config file: /etc/opt/remi/php73/php-fpm.d/web385.conf
    01.11.2021-14:03 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    01.11.2021-14:03 - DEBUG - Trying to use Systemd to restart service
    01.11.2021-14:03 - DEBUG - safe_exec cmd: systemctl is-enabled 'php73-php-fpm' 2>&1 - return code: 1
    01.11.2021-14:03 - DEBUG - Failed to use Systemd to restart service php73-php-fpm, we try init script instead.
    01.11.2021-14:03 - DEBUG - Using init script to restart service
    01.11.2021-14:03 - WARNING - No init script, we quit here.
    01.11.2021-14:03 - DEBUG - Restarting php-fpm:
    01.11.2021-14:03 - WARNING - We got no init command, restart or reload of php-fpm service aborted.
    01.11.2021-14:03 - DEBUG - Calling function 'restartPHP_FPM' from module 'web_module'.
    01.11.2021-14:03 - DEBUG - Trying to use Systemd to restart service
    01.11.2021-14:03 - DEBUG - safe_exec cmd: systemctl is-enabled 'php-fpm' 2>&1 - return code: 0
    01.11.2021-14:03 - DEBUG - Restarting php-fpm: systemctl reload php-fpm.service
    01.11.2021-14:03 - DEBUG - Processed datalog_id 11090
    01.11.2021-14:03 - DEBUG - Calling function 'restartHttpd' from module 'web_module'.
    01.11.2021-14:03 - DEBUG - Trying to use Systemd to restart service
    01.11.2021-14:03 - DEBUG - safe_exec cmd: systemctl is-enabled 'httpd' 2>&1 - return code: 0
    01.11.2021-14:03 - DEBUG - Restarting httpd: systemctl restart httpd.service
    01.11.2021-14:04 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    finished server.php.
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run this command:

    systemctl is-enabled 'php73-php-fpm'

    and post the result. It might be that the services exist and are maybe started, but they have not been enabled.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I just tested it for php-fpm on my centos 8 system here:

    [[email protected] ~]# systemctl is-enabled 'php-fpm'
    enabled
    [[email protected] ~]#

    So I guess the issue must be that the services are not enabled on your system.
     
  8. Steffan

    Steffan Member

    That is strange it was disabled.
    I have enabled it now
    Thanx
     
  9. Steffan

    Steffan Member

    That is strange, today again a email:
    05.11.2021-02:00 - WARNING - We got no init command, restart or reload of php-fpm service aborted.

    Code:
    CT-2 /# /bin/systemctl is-enabled php73-php-fpm
    enabled
    CT-2 /# /bin/systemctl is-enabled php71-php-fpm
    enabled
    CT-2 /# /bin/systemctl is-enabled php-fpm
    enabled
    
     

Share This Page