No html output accessing index.html

Discussion in 'Installation/Configuration' started by ionum, Sep 24, 2006.

  1. ionum

    ionum New Member

    Hi

    if i call
    http://www.domain.com/index.html nothing would displayed.

    The vconf:

    ############################################
    ServerName www.domain.com:80 /etc/apache2/vhosts/Vhosts_ispconfig.conf (22)
    ServerAdmin webmaster@domain.com /etc/apache2/vhosts/Vhosts_ispconfig.conf (23)
    DocumentRoot /srv/www/htdocs/web1/web /etc/apache2/vhosts/Vhosts_ispconfig.conf (24)
    ServerAlias domain.com /etc/apache2/vhosts/Vhosts_ispconfig.conf (25)
    DirectoryIndex index.html index.htm ind .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (26)
    ScriptAlias /cgi-bin/ /srv/www/htdocs/w .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (27)
    AddHandler cgi-script .cgi /etc/apache2/vhosts/Vhosts_ispconfig.conf (28)
    AddHandler cgi-script .pl /etc/apache2/vhosts/Vhosts_ispconfig.conf (29)
    ErrorLog /srv/www/htdocs/web1/log/error .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (30)
    AddType application/x-httpd-php .php .p .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (31)
    <Files *.php>
    SetOutputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (33)
    SetInputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (34)
    </Files>
    <Files *.php3>
    SetOutputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (37)
    SetInputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (38)
    </Files>
    <Files *.php4>
    SetOutputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (41)
    SetInputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (42)
    </Files>
    <Files *.php5>
    SetOutputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (45)
    SetInputFilter PHP /etc/apache2/vhosts/Vhosts_ispconfig.conf (46)
    </Files>
    php_admin_value open_basedir /srv/www/h .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (48)
    php_admin_value file_uploads 1 /etc/apache2/vhosts/Vhosts_ispconfig.conf (49)
    php_admin_value upload_tmp_dir /srv/www .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (50)
    php_admin_value session.save_path /srv/ .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (51)
    AddType text/html .shtml /etc/apache2/vhosts/Vhosts_ispconfig.conf (52)
    AddOutputFilter INCLUDES .shtml /etc/apache2/vhosts/Vhosts_ispconfig.conf (53)
    AddType application/vnd.wap.wmlscriptc .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (54)
    AddType text/vnd.wap.wml .wml /etc/apache2/vhosts/Vhosts_ispconfig.conf (55)
    AddType text/vnd.wap.wmlscript .ws .wml .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (56)
    AddType image/vnd.wap.wbmp .wbmp /etc/apache2/vhosts/Vhosts_ispconfig.conf (57)
    Alias /error/ "/srv/www/htdocs/web1/web .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (58)
    ErrorDocument 400 /error/invalidSyntax. .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (59)
    ErrorDocument 401 /error/authorizationR .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (60)
    ErrorDocument 403 /error/forbidden.html /etc/apache2/vhosts/Vhosts_ispconfig.conf (61)
    ErrorDocument 404 /error/fileNotFound.h .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (62)
    ErrorDocument 405 /error/methodNotAllow .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (63)
    ErrorDocument 500 /error/internalServer .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (64)
    ErrorDocument 503 /error/overloaded.htm .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (65)
    AliasMatch ^/~([^/]+)(/(.*))? /srv/www/ .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (66)
    AliasMatch ^/users/([^/]+)(/(.*))? /srv .. /etc/apache2/vhosts/Vhosts_ispconfig.conf (67)
    ############################################
    /var/log/apache2/error_log:
    ############################################
    [Sun Sep 24 12:12:26 2006] [notice] Graceful restart requested, doing restart
    [Sun Sep 24 12:12:27 2006] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations
    [Sun Sep 24 12:12:27 2006] [warn] long lost child came home! (pid 16220)
    [Sun Sep 24 12:14:25 2006] [notice] child pid 16919 exit signal Segmentation fault (11)
    [Sun Sep 24 12:14:27 2006] [notice] child pid 16920 exit signal Segmentation fault (11)
    [Sun Sep 24 12:14:28 2006] [notice] child pid 16921 exit signal Segmentation fault (11)
    [Sun Sep 24 12:14:29 2006] [notice] child pid 16922 exit signal Segmentation fault (11)
    [Sun Sep 24 12:14:52 2006] [notice] child pid 16923 exit signal Segmentation fault (11)
    [Sun Sep 24 12:14:52 2006] [notice] child pid 17641 exit signal Segmentation fault (11)
    [Sun Sep 24 12:16:15 2006] [notice] child pid 17642 exit signal Segmentation fault (11)
    [Sun Sep 24 12:16:17 2006] [notice] child pid 17643 exit signal Segmentation fault (11)

    ############################################

    Yesterday when i create a new web, it works.
    After a reinstall of the complete Server i have this problem.
    Have anybody here a solution?

    Greetings
    ionum
     
  2. ionum

    ionum New Member

    If i comment out in Vhosts_ispconfig.conf the line:
    php_admin_flag safe_mode On

    the virtual host works and i have html output.

    Does anybody know if this a php or a ispconfig "bug"?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    This in neither a PHP nor ISPConfig bug, your PHP script simply does not support safemode. If you uncheck the "PHP safemode" checkbox in the website settings from ISPConfig, PHP safemode is disabled for this website.
     
  4. ionum

    ionum New Member

    Hi Till,

    the file is index.html, contents no php.
    It is reproducible that even when the php_safe_mode is activ,
    the virtual host did not work and didn't call the webX/index.html

    httpd -S is ok.

    However, now it works, and that's the essential :)

    Thanks for your answer

    ionum
     

Share This Page