no group created

Discussion in 'Installation/Configuration' started by sageman, Sep 19, 2007.

  1. sageman

    sageman New Member

    Hi,

    after updating to to v2.2.16 I can create webs and users as usual - they can log in using FTP, all seems fine.
    But ftp-users have no rights.

    When looking at the directories and files newly created by ISPconfig they all belong to root:root.

    The corresponding user and group (say web68_info:web68) do NOT exist - very strange.

    When creating these manually I can't FTP - when recreating them with ISPconfig, I get invalid user...

    Any ideas?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any errors in /home/admispconfig/ispconfig/ispconfig.log ?
     
  3. sageman

    sageman New Member

    Well, I found this warning:

    I am using SuSE 10.1 and I think there was an issue with reiserfs and quota on my first install...
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you check in /etc/passwd and /etc/group if there are only unique user/group IDs?
     
  5. sageman

    sageman New Member

    Yes, there are double entries -
    starting with web66 which seems to be the first account with this problem.

    How should I proceed? Delete both entries and recreate with ISPConfig?

    Thanks for your time,
    Ritch
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the dupliacte UserID entries from users that where created manually on the system?
     
  7. sageman

    sageman New Member

    Yes I did create these users and groups manually, when trying to fix the issue.

    None of these 5 users show in /home/admispconfig/ispconfig/users
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Are the usernames or the numeric userID's duplicate?
     
  9. sageman

    sageman New Member

    Take a look here:

    /etc/passwd

    and /etc/group
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    I recommend that you make a backup of the files /etc/passwd, /etc/shadow /etc/group and /etc/gshadow, then delete the users and groups that you added manually and then run the commands:

    pwck
    grpck

    and let them repair your files. ISPConfig is not able to recognize your manual changes, so they conflict now with ISPConfig.
     

Share This Page