No FTP/Web-FTP login possible

Discussion in 'Installation/Configuration' started by z400, May 3, 2007.

  1. z400

    z400 New Member

    Hi :)
    At first, excuse my bad english. The School is a while ago ... :rolleyes:

    Yesterday, i ve installed ISPConfig for the first Time (on a Debian-vServer from Strato).

    The Installation was Ok. ISP-Config is still running.
    Only one Problem I can't solve. Any FTP-Access is not working (Anon-Login
    is still working!). All Login-trys fail (at Web-FTP & with my SmartFTP-Prog.)

    /var/log/syslog says:
    May  3 10:59:04 xxxxx proftpd[1463]: ([]) - FTP session opened. 
    May  3 10:59:05 xxxxx proftpd[1463]: ([]) - no such user 'username' 
    Is there a chance to help me pls? That will be great!

  2. Hans

    Hans Moderator ISPConfig Developer

    Within ISPConfig, is FTP-access enabled for the website and does the user exists indeed?

    Do you have the line:

    Include /etc/proftpd_ispconfig.conf

    within your /etc/proftpd/proftpd.conf ?

    Did you created a symlink for ISPConfig? By performing the command:

    ln -s /etc/proftpd/proftpd.conf /etc/proftpd.conf
  3. z400

    z400 New Member


    Sure. FTP-Access is enabled.

    Yes. Have a look:

    # /etc/proftpd.conf -- This is a basic ProFTPD configuration file.
    # To really apply changes reload proftpd after modifications.
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."
    ServerName			"Debian"
    ServerType				standalone
    DeferWelcome			off
    MultilineRFC2228		on
    DefaultServer			on
    ShowSymlinks			on
    TimeoutNoTransfer		600
    TimeoutStalled			600
    TimeoutIdle			1200
    DisplayLogin                    welcome.msg
    DisplayFirstChdir               .message
    ListOptions                	"-l"
    DenyFilter			\*.*/
    # Uncomment this if you are using NIS or LDAP to retrieve passwords:
    #PersistentPasswd		off
    # Uncomment this if you would use TLS module:
    #TLSEngine 			on
    # Uncomment this if you would use quota module:
    #Quotas				on
    # Uncomment this if you would use ratio module:
    #Ratios				on
    # Port 21 is the standard FTP port.
    Port				21
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances			30
    # Set the user and group that the server normally runs at.
    User				nobody
    Group				nogroup
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask				022  022
    # Normally, we want files to be overwriteable.
    AllowOverwrite			on
    # Delay engine reduces impact of the so-called Timing Attack described in
    # It is on by default. 
    #DelayEngine 			off
    # A basic anonymous configuration, no upload directories.
    # <Anonymous ~ftp>
    #   User				ftp
    #   Group				nogroup
    #   # We want clients to be able to login with "anonymous" as well as "ftp"
    #   UserAlias			anonymous ftp
    #   # Cosmetic changes, all files belongs to ftp user
    #   DirFakeUser	on ftp
    #   DirFakeGroup on ftp
    #   RequireValidShell		off
    #   # Limit the maximum number of anonymous logins
    #   MaxClients			10
    #   # We want 'welcome.msg' displayed at login, and '.message' displayed
    #   # in each newly chdired directory.
    #   DisplayLogin			welcome.msg
    #   DisplayFirstChdir		.message
    #   # Limit WRITE everywhere in the anonymous chroot
    #   <Directory *>
    #     <Limit WRITE>
    #       DenyAll
    #     </Limit>
    #   </Directory>
    #   # Uncomment this if you're brave.
    #   # <Directory incoming>
    #   #   # Umask 022 is a good standard umask to prevent new files and dirs
    #   #   # (second parm) from being group and world writable.
    #   #   Umask				022  022
    #   #            <Limit READ WRITE>
    #   #            DenyAll
    #   #            </Limit>
    #   #            <Limit STOR>
    #   #            AllowAll
    #   #            </Limit>
    #   # </Directory>
    # </Anonymous>
    Include /etc/proftpd_ispconfig.conf
    There is no Dir proftpd at /etc. The proftpd.conf exists at /etc/proftpd.conf

    Thx for help so far...
    Last edited: May 3, 2007
  4. z400

    z400 New Member

    Nobody any Ideas?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enable the FTP checkbox in the website settings?
  6. z400

    z400 New Member

    Yes, i did. If I enable Anonymus-FTP, it even works.
    But its no User Access possible...
  7. falko

    falko Super Moderator ISPConfig Developer

    Is the user that you try to log in with listed in /etc/passwd?
  8. Toyer

    Toyer New Member

    I have exactly the same symptoms (though it is not an Strato Server but also Etch).
    In my case NO customers created with ISPConfig can be fount in /etc/passwd
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    @Toyer: Please make a new thraed if possible. This thread is not finished yet and it wil end in confusion if we handle possibly different problems in it.
  10. z400

    z400 New Member

    Excuse my late reply here.
    I did a new Installation of my vServer, so i cant have a look, if this was so.
    After this new Installation of my Server, an a re-Install of ISPCondig, it all runs fine.
    ISPConfig is a really fine thing!! Thanks for developing!
  11. cliffo4

    cliffo4 New Member

    I have just setup my system and have setup one Client and one site. The client name does not appear in the /etc/passw file. The other settings you have asked to check above all match as well. This is a Suse10.2 system

    The ftp port is open, and the client connects and takes around 5 seconds for a prompt from ProFTPD to come back (220 ProFTPD 1.3.0a Server (ProFTPD Default Installation)).

    Installation was completed by following the howtoForge pages for Suse 10.2,

    Any further way of tracing why the user is not in the /etc/passw file?
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this explains the problems. Clients can only log into the ISPConfig webinterface but never with FTP. You must create a user on the email & User tab of the website and enable the "administrator" checkbox for this user. This is described in the manuals too ;)

Share This Page