No Email

Discussion in 'Installation/Configuration' started by mpl, Dec 4, 2010.

  1. mpl

    mpl New Member

    Good Day All,
    Can anyone take a look at my mail log below and point me in the right direction please? I know I have missed something! I need help troubleshooting no email internally or externally. What additional information do I need to provide?

    I built the system following this HowTo:
    http://www.howtoforge.org/perfect-server-centos-5.2-ispconfig-3

    I followed everything in this HowTo except I built postfix from postfix-2.3.3-2.1.mysql_pgsql.src.rpm. Could not find the Postfix file in the tutorial. Maybe this is the issue??

    I have checked and rechecked my config files and I am lost ;-(





    "Dec 4 16:31:56 kd8q postfix/qmgr[14576]: 5CA3D2F6885: from=, size=498, nrcpt=1 (queue active)
    Dec 4 16:32:06 kd8q postfix/smtp[18572]: 5CA3D2F6885: to=, relay=none, delay=7553, delays=7543/0.12/10/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=kd8q.com type=MX: Host not found, try again)
    Dec 4 16:35:01 kd8q postfix/smtpd[18733]: connect from localhost.localdomain[127.0.0.1]
    Dec 4 16:35:01 kd8q postfix/smtpd[18733]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]"


    Thank you in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the nameservers that are listed in /etc/resolv.conf are reachable from your server and that they are working.
     
  3. mpl

    mpl New Member

    Thanks for the reply Till! DNS resolves as the website is up. Here is the dig:

    ; <<>> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_4.2 <<>> mail.kd8q.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13215
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail.kd8q.com. IN A

    ;; ANSWER SECTION:
    mail.kd8q.com. 600 IN A 184.57.213.175

    ;; Query time: 163 msec
    ;; SERVER: 192.168.1.1#53(192.168.1.1)
    ;; WHEN: Sun Dec 5 13:06:52 2010
    ;; MSG SIZE rcvd: 47
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that you have a valid MX record for kd8q.com
     
  5. mpl

    mpl New Member

    OK. Got the MX record problem resolved. Now the connection is refused on port 25 of the server?? Is this an ISPConfig 3 configuration problem? Checked my router ports and is being forwarded to the server.
     
  6. mpl

    mpl New Member

    BTW...I can connect to port 25 via localhost and postfix queues mail but it does not seem to go anywhere??
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    ,
    Code:
    iptables -L
    , and
    Code:
    postqueue -p
    ?

    Also make sure that your ISP doesn't block port 25.
     
  8. mpl

    mpl New Member

    Hello Falco,
    THanks so much for your help! Here you go...

    Ohh, and the port is open to the server. I can now telnet into port 25
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Do you have valid nameservers in /etc/resolv.conf? What's in your /etc/resolv.conf?
     
  10. mpl

    mpl New Member

    Hello Falco,
    Here is resolv.conf
    [[email protected] etc]# cat /etc/resolv.conf

    search kd8q.com
    nameserver 192.168.1.1
     
  11. mpl

    mpl New Member

    Ok, now we are getting somewhere. I corrected resolv.conf by adding ISP's nameserver. Now i can send mail but not recieve.

    Here is the error in the mail error log:

    Dec 7 19:07:38 kd8q postfix/smtpd[24244]: NOQUEUE: reject: RCPT from cpe-184-57-213-175.cinci.res.rr.com[184.57.213.175]: 550 5.1.1 : Recipient address rejected: User unknown in local recipient table; from= to= proto=SMTP helo=

    Here is an error from Squrrillmail:

    Dec 7 19:07:38 kd8q postfix/smtpd[24244]: NOQUEUE: reject: RCPT from cpe-184-57-213-175.cinci.res.rr.com[184.57.213.175]: 550 5.1.1 : Recipient address rejected: User unknown in local recipient table; from= to= proto=SMTP helo=

    And here is an error from Outlook Express:

    The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was '[email protected]'. Subject 'test', Account: '[email protected]', Server: 'mail.kd8q.com', Protocol: SMTP, Server Response: '550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in local recipient table', Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC79

    Now I am thinking I have a postfix mysql problem??? Does that sound resonable? How do I troubleshoot?

    Thanks!
     
  12. mpl

    mpl New Member

  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Post the output of:

    ls -la /usr/sbin/sendmail
     
  14. mpl

    mpl New Member

    Hi Till!
    Here you go ;)
    [email protected] web3]# ls -la /usr/sbin/sendmail
    lrwxrwxrwx 1 root root 21 Nov 26 11:50 /usr/sbin/sendmail -> /etc/alternatives/mta
    [[email protected]

    Thanks for your help!
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, and now:

    ls -la /etc/alternatives/mta

    If it points to another symlink, then post the ls -la for the target too.
     
  16. mpl

    mpl New Member

    Ok Till, here you go!
    [email protected] web3]# ls -la /etc/alternatives/mta
    lrwxrwxrwx 1 root root 27 Nov 26 15:53 /etc/alternatives/mta -> /usr/sbin/sendmail.sendmail
    [email protected] web3]# ls -la /usr/sbin/sendmail.sendmail
    -rwxr-sr-x 1 root smmsp 806460 Mar 31 2010 /usr/sbin/sendmail.sendmail

    That's where the trail ends!

    Thanks again for your help ;)
     
  17. mpl

    mpl New Member

    I am thinking this link is wrong. Should it not be pointing to /usr/sbin/sendmail.postfix ?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Does /usr/sbin/sendmail.postfix exist? Do you use Postfix? If so, you can change the symlink as follows:
    Code:
    ln -sf /usr/sbin/sendmail.postfix /etc/alternatives/mta
     
  19. mpl

    mpl New Member

    Thanks for everything Falco! I had too many issues on the Centos installation so I started over with Debian Lenny ;-) I hated to give up but since IspConfig3 was built on Debian, I figured I would have better success with that!
     

Share This Page