No email sent ( Postfix )

Discussion in 'Server Operation' started by szise, Jul 4, 2008.

  1. szise

    szise New Member

    I have a problem with postfix, is not sending emails :

    this is from the mail.log :

    When i check with tells me the mx records are working properly but checking :

    dig domain mx

    i see i don't have authoritative mx records and emails are not sent

    What to do ?
    Last edited: Jul 4, 2008
  2. topdog

    topdog Active Member HowtoForge Supporter

    The DNS on your mail server is not working. check that you have correct DNS servers in /etc/resolv.conf
  3. szise

    szise New Member

    yes in resolv.conf are my nameservers
  4. topdog

    topdog Active Member HowtoForge Supporter

    they are clearly not working

    dig mx @your_server_ip
  5. szise

    szise New Member

    this is what i get

  6. topdog

    topdog Active Member HowtoForge Supporter

    As you can see the DNS server is not returning any answer. You need to use servers that will respond, if your servers are not working use the opendns servers.
  7. szise

    szise New Member

    ok but why are not working ? also related to my IPs Godaddy sais "errors were detected" when i try to add my IPs , nameservers for a domain name in their panel.
  8. topdog

    topdog Active Member HowtoForge Supporter

    Dude you need to understand how DNS works, there is authoritative and recursive. The DNS servers you configure with godaddy are your authoritative name servers. You need recursive name servers for you to be able to resolve other peoples domain names.
  9. szise

    szise New Member

    i don't have nameservers setup with Godaddy , i have setup my nameservers on my server

  10. falko

    falko Super Moderator ISPConfig Developer

  11. szise

    szise New Member

    thanks i replaced the nameservers in the resolv.conf and now postfix is sending emails

Share This Page