no email after changed domain to own IP?

Discussion in 'General' started by carpman, Jun 28, 2013.

  1. carpman

    carpman Member

    Hi, have given 2 domains their own IPs and set dns to reflec new IP address.

    The web works fine, but now email is not working when using remote client?

    It is working when i use webmail?

    accounts on shared IP work fine.

    a test via remote telnet confirms this?

    Any ideas why?

    thanks
     
    Last edited: Jun 28, 2013
  2. tahunasky

    tahunasky New Member

    When you say "remote client" do you mean a client (outlook/thunderbird/live mail etc) from a remote location outside your local LAN ?

    If so have you checked that the ports are open on the router/server, and being forwarded from router to server, and that the client is using the correct ports.

    Webmail uses port 80/443, where a client will use port 110/995 for pop3, 143/993 imap and 25/587 smtp usually depending on your setup.
     
  3. carpman

    carpman Member

    Yes mean email client.

    It is not a port issue as i can connect to other email accounts on the server that use the shared IP, it is just the 2 domains that i have allocated there own dedicated IP address!

    I have tried to telnet to newipdomains.com on port 25 and 587 from both remote machine and on the server, but get connection refused error on both?
     
  4. carpman

    carpman Member

    I thought my IP may have been banned, but get same issue using mobile network.

    check fail2ban to make sure and does not have any banned IPs

    iptables -L -n
    Code:
    Chain INPUT (policy ACCEPT)
    target     prot opt source               destination         
    fail2ban-ssh  tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 22 
    fail2ban-pureftpd  tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 21 
    fail2ban-dovecot-pop3imap  tcp  --  0.0.0.0/0            0.0.0.0/0           multiport dports 110,995,143,993 
    
    Chain FORWARD (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain OUTPUT (policy ACCEPT)
    target     prot opt source               destination         
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    target     prot opt source               destination         
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0           
    
    Chain fail2ban-pureftpd (1 references)
    target     prot opt source               destination         
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0           
    
    Chain fail2ban-ssh (1 references)
    target     prot opt source               destination         
    RETURN     all  --  0.0.0.0/0            0.0.0.0/0   
    tried an unban just in case, but get error

    Code:
    iptables -D fail2ban-dovecot-pop3imap -s HomeIP -j DROP
    ptables: Bad rule (does a matching rule exist in that chain?).
     
    Last edited: Jun 29, 2013
  5. carpman

    carpman Member

    A check on mxhealthcheck.com give the domain the all clear !

    thanks
     
  6. carpman

    carpman Member

    Di need to edit postfix main.cf and set

    Code:
    smtp_bind_address
    thanks
     
  7. carpman

    carpman Member

    anyone have any idea why this happened as really need to get my emails working again!

    thanks
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, dont bind the IP there as mail delivery will stop then.

    Please post the output of:

    netstat -tap
     

Share This Page