No DKIM after changing to Rspamd

Discussion in 'Installation/Configuration' started by George Girgolas, Mar 16, 2022.

  1. George Girgolas

    George Girgolas New Member

    I have a debian server(latest updates) and I also followed the guide on replacing amavis with rspamd. No DKIM is used thought..

    Take a lookon the output of the commands

    Code:
    [email protected]:/etc/rspamd# ls /var/lib/rspamd/dkim/
    ls: cannot access '/var/lib/rspamd/dkim/': No such file or directory
    [email protected]:/etc/rspamd# cat /etc/rspamd/local.d/dkim_selectors.map
    [email protected]:/etc/rspamd# cat /etc/rspamd/local.d/dkim_domains.map
    [email protected]:/etc/rspamd# ls -la /var/lib/amavis/dkim/
    total 8
    drwxr-x--- 2 amavis amavis 4096 Jan 22  2021 .
    drwxr-x--- 7 amavis amavis 4096 Mar 16 08:30 ..
    Any thoughts?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Neither does my server with working Rspamd and DKIM have this directory:
    Code:
    /var/lib/rspamd/dkim/
    Have you set up DKIM for an e-mail domain?
     
  3. George Girgolas

    George Girgolas New Member

    I guess I haven't...Could you please advise how to?
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    ISPConfig Panel | E-mail tab | Email Accounts | Domain | Choose a domain | Press "Domainkeys identified mail (DKIM)" , "Enable DKIM", "Generate DKIM Private key".
    If your DNS is handled by ISPCOnfig, the keys are copied to name service automatically. If DNS is somewhere else, you must copy the keys yourself. There are discussion on this forum about this.
    ISPConfig has manual: https://www.ispconfig.org/documentation/
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Try editing a mail domain and save again (maybe disable dkim then enable again) and see if it works for that one domain.
     

Share This Page