No changes made to any config file

Discussion in 'General' started by adm-computers, Aug 17, 2008.

  1. adm-computers

    adm-computers New Member

    I have a rather small (well Large) problem where any changes made in ISPConfig aren't written to any config file. New sites aren't setup and DNS entries aren't setup or removed properly. I've looked for ispconfig.log but that doesn't exisit. Any ideas?

    Writeconf.php has just failed on a segmenation fault!!! took 4 minutes to come through - I have also followed the php downgrade by Till
    Last edited: Aug 17, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the permissions of the bind directories are wrong. Please reconfigure bind as described in the perfect setup guide for your linux distribution. Downgrading PHP is not nescessaery and not recommended for the current releases and may cause problems.
  3. adm-computers

    adm-computers New Member

    Hi Till,

    I've done that already and it made no difference. I understand that if the bind permissions were set incorrectly then ISPConfig wouldn't be able to right to bind files, But how does this stop it writing Apache files?

    Anyway to the point, still nothing appears in apache or bind.
  4. falko

    falko Super Moderator ISPConfig Developer

    What happens when you run
    /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    on the shell?
  5. adm-computers

    adm-computers New Member

    The script runs for a bit then fails on a segmentation fault
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post the exact output?

    Which distribution are you using?
    Is it a 32bit or 64bit system?
  7. adm-computers

    adm-computers New Member

    We're currently using CentOS 5.2 32Bit.

    Out put from running the request command is: -


    [[email protected] ~]# /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php

    [[email protected] ~]#


    I've just run the command again and this is the usual response that i get


    [[email protected] ~]# /root/ispconfig/php/php /root/ispconfig/scripts/writeconf.php
    Segmentation fault
    [[email protected] ~]#

    Last edited: Aug 20, 2008
  8. falko

    falko Super Moderator ISPConfig Developer

    Can you install ISPConfig again over the existing ISPConfig installation? Hopefully this creates a working PHP...
  9. adm-computers

    adm-computers New Member

    Hi falko,

    We have tried with a re-install over the orginial system and after moving all our clients to a different server tried a fresh install of ISPConfig. We have opted to start with a fresh base install, aiming this decision as a problem somewhere within the OS. I believe it maybe an system update that may have broke the system but can't be quite sure.
  10. falko

    falko Super Moderator ISPConfig Developer

    Segmentation faults can also be caused by hardware failures. I'd check the RAM with memtest.

Share This Page