no authentication on pop / imap > Access denied for user 'ispconfig'@'localhost'

Discussion in 'Installation/Configuration' started by Djamu, May 21, 2011.

  1. Djamu

    Djamu New Member

    Seems my update troubles aren't over yet.

    I think something is wrong in either
    /etc/courier/authmysqlrc
    /etc/courier/authdaemonrc

    After updating mysql and a couple of other packages my courier-imap & pop seems to be dead.
    Mails are getting delivered but I can not retrieve them.

    Ispconfig status shows all services online. but no imap / pop access.

    running > mysql -h localhost -u ispconfig

    gives a strange result as with phpmyadmin I can login as user ispconfig and the password provided in authmysqlrc

    ( i'm getting > Access denied for user 'ispconfig'@'localhost' )
    are those brackets normal ?

    I did a manual update > php -q update.php on the extracted source allready.
    and had to reinstall maildrop to squash another issue
    but now i'm out of ideas

    system = debian squeeze

    netstat -tap looks normal

    Code:
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      2239/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      4001/master
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      12169/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN      1928/portmap
    tcp        0      0 *:ssmtp                 *:*                     LISTEN      4001/master
    tcp        0      0 *:epmd                  *:*                     LISTEN      3382/epmd
    tcp        0      0 *:munin                 *:*                     LISTEN      4318/munin-node
    tcp        0      0 *:ftp                   *:*                     LISTEN      4016/pure-ftpd (SER
    tcp        0      0 hosted-by.leasew:domain *:*                     LISTEN      3897/mydns
    tcp        0      0 3d.uk.to:domain         *:*                     LISTEN      3897/mydns
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      3897/mydns
    tcp        0      0 *:ssh                   *:*                     LISTEN      2214/sshd
    tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN      4190/cupsd
    tcp        0      0 localhost.localdoma:855 *:*                     LISTEN      4071/famd
    tcp        0      0 *:47511                 *:*                     LISTEN      3496/beam
    tcp        0      0 *:3000                  *:*                     LISTEN      3910/ntop
    tcp        0      0 *:smtp                  *:*                     LISTEN      4001/master
    tcp        0      0 3d.uk.to:ssh            eu62-88-25-20.ads:56426 ESTABLISHED 2229/sshd: [email protected]
    tcp        0      0 localhost.localdom:epmd localhost.localdo:47226 ESTABLISHED 3382/epmd
    tcp        1      0 localhost.localdo:58027 localhost.localdo:mysql CLOSE_WAIT  2470/amavisd (ch2-a
    tcp        0      0 3d.uk.to:ssh            eu62-88-25-20.ads:56427 ESTABLISHED 2230/sshd: [email protected]
    tcp        0      0 localhost.localdo:47226 localhost.localdom:epmd ESTABLISHED 3496/beam
    tcp        0      0 3d.uk.to:ssh            eu62-88-25-20.ads:56428 ESTABLISHED 2231/sshd: [email protected]
    tcp        1      0 localhost.localdo:41393 localhost.localdo:mysql CLOSE_WAIT  2471/amavisd (ch2-a
    tcp        0      0 3d.uk.to:ssh            eu62-88-25-20.ads:56749 ESTABLISHED 11958/sshd: [email protected]
    tcp        0    248 3d.uk.to:ssh            eu62-88-25-20.ads:56466 ESTABLISHED 5083/0
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3237/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      3332/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      3256/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      3199/couriertcpd
    tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      4264/apache2
    tcp6       0      0 [::]:www                [::]:*                  LISTEN      4264/apache2
    tcp6       0      0 [::]:tproxy             [::]:*                  LISTEN      4264/apache2
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      4016/pure-ftpd (SER
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      3897/mydns
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2214/sshd
    tcp6       0      0 localhost:ipp           [::]:*                  LISTEN      4190/cupsd
    tcp6       0      0 [::]:https              [::]:*                  LISTEN      4264/apache2
    
    thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats ok.

    Please check taht the mysql password in the courier config for the ispconfig user is the same then the password that you find in /usr/local/ispconfig/server/lib/config.inc.php and that you are able to login with the login details of the config.inc.php file into the ispconfig mysql database.
     
  3. Djamu

    Djamu New Member

    thanks for the quick reply

    yes the password in /usr/local/ispconfig/server/lib/config.inc.php is identical

    with phpmyadmin I can login using those credentials
     
  4. Djamu

    Djamu New Member

    mmm I found that the password in the mysql database > user ispconfig is different from the other passwords..

    shouldn't those be identical ?
     
  5. Djamu

    Djamu New Member

    ok I made sure the database mysql user ispconfig entry is identical...

    I can login using mysql -h localhost -u ispconfig -p


    still no imap / pop access :confused:
     
    Last edited: May 21, 2011
  6. Djamu

    Djamu New Member

    Fixed !

    solution was kind of stupid.....

    as I didn't get any errors in my logs, and I was out of options
    ( triple checked everything )
    I decided to toggle all mail accounts off / on .... & lo and behold ...
    It works

    :eek: :p
     

Share This Page