No Administrator checkbox visible

Discussion in 'General' started by pcxtra, Jan 5, 2010.

  1. pcxtra

    pcxtra New Member

    Since my upgrade to ISPconfig 2.2.35 I don't have a ' Administor' checkbox within the user e-mail form.

    When I go to a site, and list the e-mail/users then I do see the admin column. However when I open a user then the checkbox 'Administrator' is gone and I cannot set / unset the site FTP administrator. I checked the form editor and it is nicely set to visible.

    It dissapeared after I've upgraded to 2.2.35 about one week ago.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I will check this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    There must be a problem with the update on your server. It seems to be that the doctype table has not been filled with the updated doctypes or that you installed a database of a prior ispconfig version.

    Please download ISPConfig 2.2.35 again and run the setup script to do the update again.
  4. pcxtra

    pcxtra New Member

    Thanks for your response however re-upgraded was not an option for me.

    I had too much trouble already with the upgrade. Besides that I've modified some files. E.g. isp_username.plugin.php as I don't use the web prefix, but use the domainname.com_admin structure and isp_username.plugin.php to disallow to edit the e-mail. This allows users to login with their normal e-mail account ([email protected]). For dovecot I've added auth_username_format = "%Ld_%Ln" to allow also normal e-mail login. I've increased the user_username column of isp_isp_user to 50 and my linux fedora 12 allows the large user names (length of 38is my largest one).

    Anyway, I manager to fix the loss of the Administrator checkbox. I first made a backup of the database. Used the form editor to changed the isp ISP user form and editted the current user_admin and renamed to user_admin2. Then I made a new user_admin checkbox with a name and defaults. Then I run an sql update:
    update isp_isp_user set user_admin = user_admin2
    this will restore the admin flags.

    Now I'm able to see the administrator checkbox when I'm editing the e-mail details for a customer. So far it's working properly now!

    So thanks to your direction I was managing to fix it.

Share This Page