No address associated with hostname

Discussion in 'Server Operation' started by Al1937, Sep 4, 2012.

  1. Al1937

    Al1937 New Member

    I installed Ubuntu 12.04 as per howtoforge instructions
    Squrrelmail & Isp3 come up fine with 192.198.0.100 but have no internet connection. The name of my server is server1
    I own the domain bingftp.com
    I am running puTTy on my workstation machine running Windows 7 Home.
    My router is a Dlink dr601 with a 8.8.8.8 8.8.4.4 DNS setuo
    Also Local Area Connection iPv4 is set for 8.8.8.8 8.8.4.4 on my workstation
    What do I still need to do to make the internet recognize my server1.bingftp.com server?
    I first tried to set up a server 9.04 in 2009- Gave up after 2 month of frustration. Trying once more.
    Please help.

    Some info:
    root@server1:~# dig server1.bingftp.com

    ; <<>> DiG 9.8.1-P1 <<>> server1.bingftp.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 14655
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1.bingftp.com. IN A

    ;; AUTHORITY SECTION:
    bingftp.com. 1800 IN SOA ns1.underpricedhost.com. underpricedhost.gmail.com. 2012082701 86400 7200

    3600000 86400

    ;; Query time: 173 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Mon Sep 3 21:39:56 2012
    ;; MSG SIZE rcvd: 115

    root@server1:~# dig bingftp.com

    ; <<>> DiG 9.8.1-P1 <<>> bingftp.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32542
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;bingftp.com. IN A

    ;; ANSWER SECTION:
    bingftp.com. 13865 IN A 71.226.21.246

    ;; Query time: 44 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Mon Sep 3 21:40:43 2012
    ;; MSG SIZE rcvd: 45

    root@server1:~# tracert6 bingftp.com
    bingftp.com port 33434: Name or service not known
    root@server1:~#


    root@server1:~# tracert6 server1.bingftp.com
    server1.bingftp.com port 33434: No address associated with hostname
    root@server1:~#

    root@server1:~# ifconfig -a
    eth0 Link encap:Ethernet HWaddr 00:b0:d0:17:ea:31
    inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::2b0:d0ff:fe17:ea31/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:432911 errors:0 dropped:0 overruns:1 frame:0
    TX packets:128021 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:255414580 (255.4 MB) TX bytes:11606931 (11.6 MB)
    Interrupt:11 Base address:0xc00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:12460 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12460 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:992087 (992.0 KB) TX bytes:992087 (992.0 KB)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you ping google.com?

    Code:
    ping -c4 google.com
    If not, do you use the correct network settings in /etc/network/interfaces? Do you use the correct gateway?
     
  3. Al1937

    Al1937 New Member

    root@server1:~# ping -c4 google.com
    PING google.com (74.125.229.193) 56(84) bytes of data.
    64 bytes from mia04s05-in-f1.1e100.net (74.125.229.193): icmp_req=1 ttl=49 time=50.2 ms
    64 bytes from mia04s05-in-f1.1e100.net (74.125.229.193): icmp_req=2 ttl=49 time=49.6 ms
    64 bytes from mia04s05-in-f1.1e100.net (74.125.229.193): icmp_req=3 ttl=49 time=49.1 ms
    64 bytes from mia04s05-in-f1.1e100.net (74.125.229.193): icmp_req=4 ttl=49 time=47.9 ms

    --- google.com ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3004ms
    rtt min/avg/max/mdev = 47.920/49.222/50.200/0.867 ms
    root@server1:~#
     
  4. TiTex

    TiTex New Member

    tracert6 is an IPv6 diag tool ... if you don't have an AAAA record in your dns it won't work
    use tracert
     
  5. Al1937

    Al1937 New Member

    Because of the problems I have seen with people upgrading from a working 11.04 to 12.04 I reinstalled 11.04.
    I gave up on bingftp.com and started from scratch. I purchased a new domain,
    akbpro.com -nameservers are with underpricedhost.com
    I followed the the perfect server ubuntu 11.04.using server1.akbpro.com
    I did not do the additional notes about VPSID. I have no idea if I have a virtual machine or what my VPSID is or how to find it.
    Anyway, after installing ispconfig3 the instructions state that I can go to
    https://server1.akbpro.com:8080- don't work!
    https://192.168.0.100:8080 works after I accept the cert. exception
    http://192.169.0.100/webmail also works but not http:// server1.akbpro.com/webmail or http://akbpro.com/webmail or http://www.akbpro.com/webmail.
    I double,tripled checked every instruction to be sure I did not have any typo errors. I seem to be the only one with this problem? What am I missing?
    Ping -c4 google.com works fine
    tracert in ubuntu does not work.
    I did tracert for the CMD prompt on both server1.akbpro.com and akbpro.com
    the result of the tracert ended at 208.68.32.146 which is an OPENDNS address.
    My Dlink router is set at it's default as is my windows local area connections for IPv4.
    I haven't messed with any bind files or resolv.conf to set up any DNS.
    Please help. This driving me absolutely NUTS!
    I must be missing something real basic.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. Al1937

    Al1937 New Member

    I had previously said I was missing something basic. Boy was I right and also was I dumb. I had the wrong concept of a server, thinking it would host my domain.
    You said my problems were all DNS problems. That got me to thinking. I needed to have my domain hosted before I could take care of the "DNS problems". Once done--- no more problems.
    Thanks for all your help.
     
  8. Al1937

    Al1937 New Member

    With my registrar:- how do I set up Dns zones for server1.akbpro.com ?
    I went ahead and used Ubantu 12.04
    I realize that FQDN is server1.akbpro.com. ending with a dot

    root@server1:~# dig server1.akbpro.com

    ; <<>> DiG 9.8.1-P1 <<>> server1.akbpro.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9388
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1.akbpro.com. IN A

    ;; ANSWER SECTION:
    server1.akbpro.com. 14400 IN A 64.20.44.250

    ;; Query time: 167 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri Sep 14 13:48:05 2012
    ;; MSG SIZE rcvd: 52

    root@server1:~# dig server1

    ; <<>> DiG 9.8.1-P1 <<>> server1
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 43947
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;server1. IN A

    ;; AUTHORITY SECTION:
    . 1645 IN SOA a.root-servers.net. nstld.verisign-grs.com. 2012091401 1800 900 604800 86400

    ;; Query time: 42 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Fri Sep 14 13:48:48 2012
    ;; MSG SIZE rcvd: 100

    root@server1:~#
     
  9. Al1937

    Al1937 New Member

  10. Al1937

    Al1937 New Member

Share This Page