Nightmare Install on Jessie/Testing, but I figured out most of it.

Discussion in 'Installation/Configuration' started by mpyusko, Sep 26, 2013.

  1. mpyusko

    mpyusko New Member

    Ispconfig3 not listening on port 8080, port closed.

    I followed the Perfect Server Wheezy/Apache,etc and ran into several new undocumented issues because of changes with Jessie but I manage to work through them (and contrary to what one post suggested, I did not need to reformat everything and start over). Apache2 by default includes *.conf files in it's startup, but ISPconfig requires *.vhost files to run properly. Without them none of the sites (even ispconfig3 on 8080) will load or listen properly. I had to add the following line to /etc/apache2/apache2.conf
    IncludeOptional sites-enabled/*.vhost
    After that i had to remove all +&- from the *.vhost files. After I would make configuratin changes, apache2 would automatically restart. When that would happen, it would fail because the + & - would come back. I had to edit the master apps.vhost file in /usr/local/ispconfig/server/conf/apache_apps.vhost.master to remove the + & - from the Options lines.

    Once I did all that, ISPconfig3 loads up and runs properly, Though I get NameVirtualHost errors
    Restarting web server: apache2AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.vhost:8
    because apparently they are being removed from Apache and they are inserted everywhere by configuration scripts.

    The problem I am facing now is when I create a website, document root folders are not made until I create an FTP user for each website. Even then, the *../web folder the server requires the site content to be in must be created manually. Is there any way to create that folder automatically? Maybe even change the name of it to public_html like is standard in so many other server configurations?

    Another problem is, I have the 3 domains on this server.,, and "" is where ISPconfig3 is served from and ( The other two are client sites, though I am technically the client. Is there A way to cleanly use ISPconfig3 to manage It was configured in Apache, long before ISPconfig3 was, but I removed 000-default.conf and default-ssl.conf from sites-enabled. (All 3 sites should use a self-signed SSL connection since this is a development server where I build sites prior to publishing them on my production machines.)

  2. mpyusko

    mpyusko New Member

    To expand...
    Under Server Config > Web

    Website path : /var/www/clients/[client_username]/[website_domain]
    literally creates "/var/www/clients/[client_username]/[website_domain]/" instead of "/var/www/clients/myself/".
    Website symlinks : /var/www/[website_domain]:/var/www/clients/[client_username]/[website_domain]/
    literally creates a symlink " -> /var/www/clients/[client_username]/[website_domain]/" and not " -> /var/www/clients/myself/"

    client1 and web3 are awkward to piece together, so I would prefer this format. Why is this acting so glitchy? I'd love it if it automatically created "/var/www/clients/myself/" so it is obvious where to upload the site to. How can I fix this?


Share This Page