NIC porblem with Fedora Core 7

Discussion in 'Installation/Configuration' started by randallp, Jul 9, 2007.

  1. randallp

    randallp New Member

    I cannot get eth0 to activate under fedora core 7. It had worked just fine under 3. My configuration had my DSL modem going to a netgear wireless router. I have the core 7 box pugged in to port two on the back of the router, the same place it was under 3. I am currently trying to use DHCP. Once I get a connection established I can start pulling down all my updates, I know there will be a ton for 7. I was expecting a lot of glitches but not one involving a NIC that had been reconized in a prior version. Perhaps I am forgetting something as it has been awhile since I installed 3.
     
  2. 40esp

    40esp New Member

    check these files:

    vi /etc/sysconfig/network --- make sure your hostname and gateway(192.168.0.1) are set properly.


    vi /etc/sysconfig/network-scripts/ifcfg-eth0

    make sure everything is as during your install.

    vi /etc/resolv.conf

    make sure either your router or isps dns servers are listed.


    after making changes please use this command:

    /etc/init.d/network restart

    ------

    if still not working, copy your mac address and go into your router. set a static for your mac.

    edit your eth0 conf to accept static:

    DEVICE=eth0
    BOOTPROTO=static
    BROADCAST=192.168.0.255
    IPADDR=your static ip
    NETMASK=255.255.255.0
    NETWORK=192.168.0.1
    ONBOOT=yes


    after that you should be fine.

    preform a network restart /etc/init.d/network restart

    or a system restart: shutdown -r now

    hope that helps.
     
  3. randallp

    randallp New Member

    No Joy

    I think the problem goes deeper. I don't think fedora core 7 is recognizing my NIC. Are there any tests I can perform, or any particular RPMs I can download.
    Once I get over this hurtle I can utilize Yum to update my system.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    ifconfig
    and
    Code:
    lspci
    ?
     
  5. randallp

    randallp New Member

    ifconfig

    eth0 Link encap:Ethernet HWaddr 00:30:1B:2A:1D:88
    inet6 addr: fe80::230:1bff:fe2a:1d88/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:3 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:5 Base address:0xce00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:6956 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6956 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:41786152 (39.8 MiB) TX bytes:41786152 (39.8 MiB)


    ispci

    No manual entry for ispci :confused:
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The command is lspci, not ispci...

    Anyway, eth0 is up, so all you need to do is assign an IP address to it. You can do this manually for testing purposes with the ifconfig command, e.g. like this:
    Code:
    ifconfig eth0 up 192.168.0.100
    Take a look at
    Code:
    man ispconfig
     
  7. randallp

    randallp New Member

    I am currently back to a static IP address and I can ping myself but I can not ping the gateway. my address is 192.168.0.50 and the gateway is at 192.168.0.1. I can also ping the localhost. In this case ifconfig eth0 up 192.168.0.50 did nothing useful. I checked the man page for ifconfig is that what you meant as there is no man page for ispconfig or lspconfig considering my pervious error. :eek:

    Thanks
    RJ
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Sorry, I meant
    Code:
    man ifconfig
    :eek:

    Are you sure that 192.168.0.1 is your gateway?
    What's in /etc/sysconfig/network-scripts/ifcfg-eth0?
     
  9. randallp

    randallp New Member

    Thanks for your help, I have solved the issue. After learning that I could get it to work when it is directly connected to the DSL modem I reexamined the patch cords. The Fry's special cat-6 patch cord I had used with Fedora Core 3 would not work with Fedora Core-7. I swapped it with the XP box that was able to use it and switched up on the Fedora box to a cat-5e cross over cable. Now I am on line. I am not sure though I had been under the impression that the cat-6 was a crossover. As I do not have any diagnostic tools to tone out the cable I will just leave it at that. Once again thanks!

    RJ
     
    Last edited: Jul 30, 2007

Share This Page