nginx works, but shows it is offline

Discussion in 'ISPConfig 3 Priority Support' started by misterm, Apr 10, 2015.

  1. misterm

    misterm Member

    Hello
    Logically, if nginx is "offline", I know not access my accommodation Meal management panel?

    If I can access and displays "Red" in the "Tracking" tab, is the what?

    Many greetings
    Mz
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that nginx is listening on port 80 on localhost.
     
  3. misterm

    misterm Member

    hello
    By running a "netstat -tap" I have this result:
    logic?
    Mz
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    According to your netstat output, you configured nginx to listen only on the external interface and not on all interfaces incl. localhost.
     
  5. misterm

    misterm Member

    Ok, Till I have not really understand your sentence, I have to add anything in nginx config for it to be "green" in my config
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    By default, nginx listens n localhost when you followed one of the perfect server guides. You must have switched that off in nginx configuration. Which Linux Distribution do you use?
     
  7. misterm

    misterm Member

    So, Debian 7.8 (Wheezy)
    It appears that I need my config file?
    thank you
    Mz
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please post the content of the nginx.conf file and did you disable or alter the nginx default vhost file?
     
  9. misterm

    misterm Member

    Till we leave this topic, because I found the problem was not the nginx.conf file, but the default file, which it found in the "sites-available" file that was no longer symbolic link to "sites-enabled" folder.

    Mz
     

Share This Page