[nginx] Wordpress permalinks => 500 Internal Server Error

Discussion in 'Installation/Configuration' started by HipsterKarl, Aug 23, 2016.

  1. HipsterKarl

    HipsterKarl New Member

    Hello!
    First of all I want to thank you for your amazing how-to's and all the support in this forum.

    I'm basically running a server like this (had to remove the link): "perfect-server-debian-wheezy-nginx-bind-dovecot-ispconfig-3"
    But I got the following problem (all solutions I found using the search did not help):
    I need to run a wordpress page but when as soon as I start using the permalinks to be the postname I just receive the error 500.

    Example:
    mysite.com/ => that's fine
    mysite.com/team => error 500
    mysite.com/services/products => error 500

    wp-admin is not affected at all.
    At the moment I am using this nginx directive:
    Code:
    location / {
    index index.php index.html index.htm;
    try_files $uri $uri/ /index.php?$args;
    }
    
    But as I said earlier...I think I have tried every solution I found so far. Could you please help me?
    Regards
     
    Last edited: Aug 23, 2016
  2. HipsterKarl

    HipsterKarl New Member

    Thanks to anybody who has taken a look into this, but it was just me being stupid.
    For some reason I had the redirect mode in ISPConfig set to "R,L" which caused the error.
    I guess this is what happens when you're awake for more than 24 hours straight...

    Thanks anyway.
     
  3. DonMcCoy

    DonMcCoy New Member HowtoForge Supporter

    this is the real reason behind 90% of our technical problems, just get a bit of rest and let your CPU get it too, and the next day you will be surprised with a new sight to your problem, :)
     

Share This Page