Nginx with Ispconfig 3 with debian 9

Discussion in 'Installation/Configuration' started by Patrick Tanis, Jun 13, 2018 at 7:54 PM.

  1. Patrick Tanis

    Patrick Tanis New Member

    I have installed nginx with php-fpm on debian 9. The issue is that any client site with php does not working. I have tried with joomla, wordpress. I see in the log file : FastCGI sent in stderr: "PHP message: PHP Warning: require_once(includes/basics.php): failed to open stream. Any help would be appreciable.

    Patrick Tanis
     
  2. Taleman

    Taleman Active Member HowtoForge Supporter

    Have you installed all the requied PHP packages and modified the configurations according to the Perfect Server Guide you followed?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    And it seems as if you have not uploaded all files of the CMS that you use in that website plus I'm not sure if you aware that most CMS need custom nginx rewrite rules as nginx does not understand the .htaccess files that ship with cms systems, .htaccess files are for apache servers only.
     
  4. Patrick Tanis

    Patrick Tanis New Member

    After failing with CMS, i use the default website and try to install kimai for testing. I got the same error.
     
  5. Patrick Tanis

    Patrick Tanis New Member

    Yes,
    I did
     
  6. Taleman

    Taleman Active Member HowtoForge Supporter

    If you create a new website, it should have an index.html file which is shown when browser goes to the URL. Does this work? And if you modify the index.html, add some text to indicate it is different from the original, does the browser now show the altered web page?
    If that works, remains to find out why PHP does not work. Add showing phpinfo() to that web page or maybe add foobar.php file containing call to phpinfo(), this is to see what PHP version with which settings is run.
     
    till and ahrasis like this.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no default website on an ISPConfig server. So if you did not copy it to the web folder of an ISPConfig website,, then the cms must fail in the folder you used. To get a website: Add a website in ISPConfig, access this website by its domain name and then follow the instructions from post #6 that taleman posted for further testing
     
  8. Patrick Tanis

    Patrick Tanis New Member

    Let me check.
    Patrick Tanis
     
  9. Patrick Tanis

    Patrick Tanis New Member

    Yes , i have made this test and phpinfo() work perfectly. I have tried to create website for clients , the same issue.
    I use php 7.0 , i will try php5, someone from other forum says the problem may come from php 7.0
    Patrick Tanis
     
  10. Taleman

    Taleman Active Member HowtoForge Supporter

    Can you be more precise about what is not working? The log in first message showed a warning only. Did the install of wordpress and joomla finish?
    You wrote you try both PHP 5.6 and 7.0, how did you install multiple PHP versions?
     
  11. Patrick Tanis

    Patrick Tanis New Member

    I can install the application with cms and php7.0-fpm if i type this command in the web folder of the client : chmod -R 777 . It seems this was a permission issue.

    Patrick Tanis
     
  12. Taleman

    Taleman Active Member HowtoForge Supporter

    ISPConfig creates a website with a user that has all needed permissions to the website directory. So if chmod 777 is needed, something is wrong. Either you did not use the website specific user, or something has been altered in the setup after ISPConfig created the website. Or something else, anyway chmod 777 should not be needed if ISPConfig is used.
     
  13. Patrick Tanis

    Patrick Tanis New Member

    Yes , you are right. I didn't use the client user. I just use the client account and it's working perfectly.
    Patrick Tanis
     

Share This Page