nginx Segmentation fault Error,The Perfect Server - CentOS 6 With nginx [ISPConfig 3]

Discussion in 'HOWTO-Related Questions' started by alihan1988, Feb 2, 2012.

  1. alihan1988

    alihan1988 New Member

    I have have tried to install The Perfect Server - CentOS 6.1 x86_64 With nginx [ISPConfig 3] at this site.:eek:

    error:
    Code:
    [[email protected] /]# service nginx stop
    [[email protected] /]# service nginx start
    Starting nginx: nginx[3452]: segfault at 0 ip 0000000000415c51 sp 00007fff7471a5c8 error 4 in nginx[400000+a1000]
    /bin/bash: line 1:  3452 Segmentation fault      /usr/sbin/nginx -c /etc/nginx/nginx.conf
    [FAILED]
    [[email protected] /]# 
    
    Linode Shell (lish) Console Output:
    Code:
    Linode Shell (lish) Console starting...-------------------------
    [[email protected] lish] 
    Bringing up interface eth0:  [  OK  ]
    Starting portreserve: [  OK  ]
    Starting system logger: [  OK  ]
    Starting named: [  OK  ]
    Starting Courier authentication services: authdaemond
    Retrigger failed udev events[  OK  ]
    cat: /proc/sys/crypto/fips_enabled: No such file or directory
    /etc/rc3.d/S55sshd: line 50: [: too many arguments
    Starting sshd: [  OK  ]
    Starting ntpd: [  OK  ]
    Starting mysqld:  [  OK  ]
    Starting clamd.amavisd: [  OK  ]
    Starting amavisd: [  OK  ]
    
    Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
    Starting postfix: [  OK  ]
    Starting spawn-fcgi: [  OK  ]
    Starting php-fpm: [  OK  ]
    Starting nginx: nginx[2271]: segfault at 0 ip 0000000000415c51 sp 00007fff61dc4538 error 4 in
    400000+a1000]
    /bin/bash: line 1:  2271 Segmentation fault      /usr/sbin/nginx -c /etc/nginx/nginx.conf
    [FAILED]
    Starting pure-ftpd: [  OK  ]
    Starting crond: [  OK  ]
    Starting fail2ban: [  OK  ]
    Starting atd: [  OK  ]
    Starting mailman: [  OK  ]
    
    CentOS release 6.2 (Final)
    Kernel 3.0.18-x86_64-linode24 on an x86_64
    
    anka.mysite.com login: root
    Password: 
    Last login: Thu Feb  2 11:23:32 on hvc0
    [[email protected] ~]# 
    ----------------------------------------------------------------------------------------------
    
    
    My system: linode xen server, ram: 512:cool:
    CentOS release 6.2 (Final)
    Kernel: 3.0.18-x86_64-linode24 on an x86_64


    I did the installation. I added a new site with ispconfig. worked flawlessly. :rolleyes:
    But, when I start the server again, this error has occurred.:mad: Please help me!
     
    Last edited: Feb 2, 2012

Share This Page