nginx ispconfig @debian - vhost changes lost every day

Discussion in 'Installation/Configuration' started by Neptun, Jun 28, 2019.

  1. Neptun

    Neptun Member

    Hi,
    i hope somebody could help with this issue:

    i have added the let's encrypt certs from the general :8080 port also to the :8081 in apps.vhost @ ngixn config, what is working perfect & i can use all apps via the :8081 port with ssl too
    but every day the file is changed from the system and set back to default & https login is lost for webmail & phpmyadmin for example

    setup in use is perfect server for debian 9 (i use 10) + nginx + php7.3 + ispconfig from the tutorials

    I had a look now everywhere also i cannot find anything in ispconfig settings, where i can apply the certs for the apps.vhost permanent of ispconfig for the :8081 port
    I know direct change of vhost files is not the best ... but no idea how to change it in another way or where (maybe i have not seen this setting ..)

    Thanks in advance for an idea how to fix this
     
  2. ahrasis

    ahrasis Well-Known Member

    Create custom conf folder for it so it won't be reset to default?
     
  3. Neptun

    Neptun Member

    How can I do this?
    You mean with an additional nginx host conf file?
    Or better - what must be inside that there is no conflict with ispconfig

    I have changed to ispconfig since 2 weeks - I am learning as much as possible at the moment about it - but to this I have nothing found what would be the best way
     
  4. zenny

    zenny Member

    Else make it immutable (man chattr).

    Code:
     # chattr +i /path/to/conf/file.conf 
     
    Neptun likes this.
  5. ahrasis

    ahrasis Well-Known Member

Share This Page