nginx: [emerg] unknown "https" variable

Discussion in 'Installation/Configuration' started by PermaNoob, Nov 19, 2013.

  1. PermaNoob

    PermaNoob Member

    Reloading php-fpm: [ OK ]
    nginx: [emerg] unknown "https" variable
    nginx: configuration file /etc/nginx/nginx.conf test failed
    Installation completed.

    -------------------
    That was at the end of the ispconfig install.
    -------------------

    Used perfect server centos 6.4 nginx ispconfig

    I just setup 2 servers. The first one no problem. The second one I'm getting that error and can't connect to the ispconfig admin page and there is no generic page for the ip.

    In another post someone said it was because of
    nginx version: nginx/1.0.15 but that is the same version on both servers, and one is working.

    Here is my nginx.conf -- it's the same on both servers:

    # For more information on configuration, see:
    # * Official English Documentation: http://nginx.org/en/docs/
    # * Official Russian Documentation: http://nginx.org/ru/docs/

    user nginx;
    worker_processes 1;

    error_log /var/log/nginx/error.log;
    #error_log /var/log/nginx/error.log notice;
    #error_log /var/log/nginx/error.log info;

    pid /var/run/nginx.pid;


    events {
    worker_connections 1024;
    }


    http {

    ## Detect when HTTPS is used
    map $scheme $https {
    default off;
    https on;
    }

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    log_format main '$remote_addr - $remote_user [$time_local] "$request" '
    '$status $body_bytes_sent "$http_referer" '
    '"$http_user_agent" "$http_x_forwarded_for"';

    access_log /var/log/nginx/access.log main;

    sendfile on;
    #tcp_nopush on;

    #keepalive_timeout 0;
    keepalive_timeout 65;

    #gzip on;

    # Load config files from the /etc/nginx/conf.d directory
    # The default server is in conf.d/default.conf
    include /etc/nginx/conf.d/*.conf;

    }
     
  2. PermaNoob

    PermaNoob Member

    nvm, it was a firewall setting in

    system-config-firewall
     

Share This Page