nginx: [emerg] bind() to ["my old IPV6"]:443 failed (99: Cannot assign requested address)

Discussion in 'General' started by Romain Guillaume, Jan 24, 2018.

  1. Romain Guillaume

    Romain Guillaume New Member

    I installed ISPConfig when my server had an IPV6 address, but now it can't.
    When I test nginx start :
    nginx -t
    nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
    nginx: [emerg] bind() to ["my old IPV6"]:443 failed (99: Cannot assign requested address)
    nginx: configuration file /etc/nginx/nginx.conf test failed
    So can anybody help me to start nginx please ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you assigned ipv6 addresses to websites, then disable the affected sites by removing the symlinks in nginx sites-enabled folder. Then restart nginx, login to ispconfig, remove / disable the ipv6 adddress in the websites and click save. This will recreate the symlinks that you removed and writes a config file without IPv6.
     
  3. Romain Guillaume

    Romain Guillaume New Member

    I commented every vhost ipv6 references then nginx started after killed processus nginx because of multiple error 98.
    I had already removed the ipv6 adresses in websites in IspConfig. Tried some saving also this time.
    I erased the ipv6 server option in ISPCONFIG's last panel.
    And finally... still unable to go to my sites. But right now I prefer reinstalling the whole thing.
     
  4. Romain Guillaume

    Romain Guillaume New Member

    Right now I reinstalled ISPConfig but it seems it can not connect with admin-admin login-passwd.
    Code:
    ~$ systemctl status nginx.service
    ● nginx.service - A high performance web server and a reverse proxy server
       Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
       Active: active (running) since mer. 2018-01-24 20:44:11 CET; 6min ago
      Process: 7065 ExecStop=/sbin/start-stop-daemon --quiet --stop --retry QUIT/5 --pidfile /run/nginx.pid (code=exited, status=0/SUCCESS)
      Process: 8367 ExecReload=/usr/sbin/nginx -g daemon on; master_process on; -s reload (code=exited, status=0/SUCCESS)
      Process: 7070 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
      Process: 7067 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)
    Main PID: 7071 (nginx)
       CGroup: /system.slice/nginx.service
               ├─7071 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
               ├─8370 nginx: worker process
               ├─8371 nginx: worker process
               ├─8372 nginx: worker process
               └─8373 nginx: worker process
    
     
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    you must use the admin-password from your setup. the default is not admin anymore.
     
  6. Romain Guillaume

    Romain Guillaume New Member

    And finally... still unable to go to my sites : I checked my sites from another network and it worked. So it brings me to the question why are my sites not accessibles from my own network connexion ?
    When I had an IPv6 access to the server it was possible, so not any more.
    Right now I am trying to configure the dns server part of ISPConfig if it can be a solution to access sites from my own connexion.
    Or a router capable of that, with OpenWRT or DD-WRT which are able to inject custom domain-name to IP address resolves via their own internal Hosts files and/or internal bundled DNS Masquerading software such as DNSmasq..?
    Or maybe resolve dns from the computer on which I do webmastering ?
    Any ideas ?
     
    Last edited: Jan 26, 2018

Share This Page