Nginx doesn´t restart after installation of ISPConfig 3

Discussion in 'Installation/Configuration' started by cyprus, Nov 5, 2011.

  1. cyprus

    cyprus New Member

    Okay here I am the last 3 days I was setting up a server from scratch with one focus getting ISPConfig running.

    I used debian with bind & courier nginx as serversoftware thttpd for cgi implemented fastcgi and squirrelmail and walked a long way.
    Everything worked fine and then I installed ISPConfig.
    In the first moment everything seems to be okay. But I couldn´t call my server via browser got a "bad gateway".
    I tried to restart nginx and got this:
    It looks like an SSL problem but there aren´t any *.pem files in my nginx folder. And I ain´t got no idea how to fix it.

    Thanx for every hint

    Cyprus
     
  2. till

    till Super Moderator

    I doubt that this setup is compatible with ispconfig. Iispconfig supports only php-fpm for php, but falko might give you more details as he implemented the nginx setup. Also thttpd is not supported as far as i know.
     
  3. falko

    falko Super Moderator

    You need at least nginx version 0.8.21 (Debian Squeeze's nginx version is 0.7.67) with PHP-FPM (not available for Debian Squeeze), and for CGI support you need to install fcgiwrap (take a look at chapter 4 on http://www.howtoforge.com/serving-cgi-scripts-with-nginx-on-debian-squeeze-ubuntu-11.04-p3 ). Thttpd is not supported.

    You can find a description for the setup for Ubuntu in the manual. If you find a PHP-FPM package and an nginx package > 0.8.21 for Squeeze, the setup should work there as well (it does for Debian Testing).
     

Share This Page