Nginx 1.6.0 + IspConfig 3 NOT WORKING

Discussion in 'Installation/Configuration' started by Rasko, Jul 1, 2014.

  1. Rasko

    Rasko New Member

    Hi everyone,
    I am about to lose my mind!
    Yesterday I installed nginx and ispconfig 3 with following this guide

    and it worked like charm but then I realized that nginx version which is coming with epel is too old and also I wanted to add ngx_pagespeed so I decided to rebuild my centos 6.5 and install nginx 1.6.0 from the source and did it. I followed all the steps from the same guide except nginx and build it manually from source.

    Everything seemed correct, nginx was working but when I tried it turned back with no results! checked ispconfig log files and they were empty, turned off iptables but it didn't help.

    I rebuilded my server like 15 times in last two days, tried changing nginx paths and everything but have no results :(

    What should I do to use ispconfig with nginx 1.6.0 (and ngx_pagespeed) ? Installing it from the epel and than building nginx again with pagespeed will help maybe?

    I am about to kick my laptop out of the window, please help!

    P.S. : English is not my native language, sorry for mistakes.
  2. srijan

    srijan New Member HowtoForge Supporter

    Please try with
  3. Rasko

    Rasko New Member

    Hey thanks for reply @srijan.

    I fixed the problem. Here is what i did (maybe it can help some people who comes from google :) ):

    -After installing fresh Centos 6.5, I followed howtoforge's guide ( and installed old nginx from epel.

    -After fixing some https errors it started working, then I stopped nginx (service nginx stop) and began to configure nginx 1.6.0 with pagespeed from the source, following googles guide but first installed some necessary packages:
    yum install pcre-devel zlib-devel
    -Googles guide:

    In this guide, i replaced nginx configure command (./configure --add-module=$HOME/ngx_pagespeed-release-${NPS_VERSION}-beta) with this:

    -After installation i created pagespeed's cache folder:
    mkdir /var/ngx_pagespeed_cache
    Then chown nginx user and group to this folder:
    chown nginx:nginx /var/ngx_pagespeed_cache

    -When i tried to start nginx it gave me this error:
    I fixed it with commenting out ssl line in /etc/nginx/sites-enabled/000-ispconfig.vhost file:
    nano /etc/nginx/sites-enabled/000-ispconfig.vhost
    Find the "ssl off;" line and comment it out with a # symbol (#ssl off; ) or simply delete the line

    After 3 crazy days, everything seems ok for now. Have a nice day.
    Last edited: Jul 2, 2014
  4. srijan

    srijan New Member HowtoForge Supporter

    Which port you worked for the NGINX?
  5. Rasko

    Rasko New Member

    what you mean which port? I did not change it so it must be :80, and I defined :8080 for the ispconfig.

Share This Page