Nextcloud blank web page with php.ini

Discussion in 'General' started by Milly, Jan 30, 2020.

  1. Milly

    Milly New Member

    Hello, I try to add Nextcloud with the How to install Nextcloud with ISPConfig 3.1 tutorial, I have done two clean installations with the The Perfect Server - Debian 10 Apache tutorial for testing.

    But by adding the settings in Sites, New website, php.ini the web page is blank, either in https or http.

    Php.ini :
    PHP:
    opcache.enable=1
    opcache
    .enable_cli=1
    opcache
    .memory_consumption=128
    opcache
    .interned_strings_buffer=8
    opcache
    .max_accelerated_files=10000
    opcache
    .revalidate_freq=1
    opcache
    .save_comments=1
    memory_limit 
    512


    If I delete the php.ini configuration it works.



    Thank you


    Excellent thanks, it works very well.

    Add in Web Domain - Rewrite HTTP to HTTPS

    FileZilla connects to the server but maybe I have something badly configured because it does not upload all the files, add nextcloud as follows:
    Code:
    cd /tmp
    
    wget https://download.nextcloud.com/server/releases/nextcloud-18.0.0.zip
    
    unzip nextcloud-18.0.0.zip
    
    chown -R root:root /var/www/clients/client0/web1/web
    
    cp -r nextcloud/* /var/www/clients/client0/web1/web
    
    chown -R web1:client0 /var/www/clients/client0/web1/web

    I also added it to fail2ban

    Code:
    nano /etc/fail2ban/filter.d/nextcloud.conf
     
    [Definition]
    failregex = ^{"reqId":".*","remoteAddr":".*","app":"core","message":"Login failed: '.*' \(Remote IP: '<HOST>'\)","level":2,"time":".*"}$
                ^{"reqId":".*","level":2,"time":".*","remoteAddr":".*","user,:".*","app":"no app in context".*","method":".*","message":"Login failed: '.*' \(Remote IP: '<HOST>'\)".*}$
                ^{"reqId":".*","level":2,"time":".*","remoteAddr":".*","user":".*","app":".*","method":".*","url":".*","message":"Login failed: .* \(Remote IP: <HOST>\).*}$
    
    
    nano /etc/fail2ban/jail.local
    
    [nextcloud]
    backend = auto
    enabled = true
    port = 80,443
    protocol = tcp
    filter = nextcloud
    logpath = /var/www/cloud.mydomain.com/private/data/nextcloud.log
    
    service fail2ban restart
    Please correct me if I have done something wrong
     
    Last edited: Jan 31, 2020
  2. recin

    recin Member

    Do you see any error in the screen if you enable display_errors?
    Try adding lines one by one until it fails to find the problematic line
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You've set a wrong memory limit. Your memory setting is 512 Bytes and not Megabytes and 512 bytes are definitely not enough for Nextcloud ;)
     
  4. corto

    corto Member

    What is the good one to put on please?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    memory_limit = 512M
     
  6. corto

    corto Member

    ok that was what i put on .
    thx
     
  7. Th0m

    Th0m Member HowtoForge Supporter

    Woops, typo in my tutorial :D Can you change this @till ?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    ok, no prob :)
     
    Th0m likes this.
  9. Milly

    Milly New Member

    Thanks, it works fine

    I have added a couple of details above, add nextcloud to fail2ban and install by terminal

    Please correct me if I have done something wrong

    Thank you
     
  10. Th0m

    Th0m Member HowtoForge Supporter

    You can leave out
    Code:
    chown -R root:root /var/www/clients/client0/web1/web
    You can also use the web installer instead of the full .zip download, which I recommend. This will also make it easier to down- and upload, since you'll have to upload one file. If your FTP is acting weird, you should check if you have the passive FTP ports opened (there are topics about this on the forum).
    Nextcloud has built-in bruteforce protection. You can also install a Nextcloud app for blocking IP's after X failed attempts.
     

Share This Page