Newbie Secondary DNS question

Discussion in 'Installation/Configuration' started by Falrish, Apr 5, 2017.

  1. Falrish

    Falrish New Member

    I am new to setting up a secondary DNS through this system, and I have it all set up. However my main issue is when I am running a dig on my primary name server the ns2 is coming back with an internal IP address.

    I have the system set up with an internal IP address of that through my Router ports to my external IP Address that I am attempting to use. My dig results are as follows (replaced external IP with, domain with as well as internal IP with
    ; <<>> DiG 9.9.5-9+deb8u10-Debian <<>> @
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29830
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
    ;; WARNING: recursion requested but not available
    ; EDNS: version: 0, flags:; udp: 4096
    ; IN A
    ;; ANSWER SECTION: 3600 IN A
    ;; Query time: 15 msec
    ;; SERVER:
    ;; WHEN: Wed Apr 05 11:28:56 EDT 2017
    ;; MSG SIZE rcvd: 128

    The section for should state (my NS2 external IP) and not (the servers internal IP).

    Can anyone help me fix this issue?
  2. linus

    linus Member

    If I understood your question correctly, in the DNS - zones - - records, you have defined the ns2 a record, you should change that to the external ip.

    What you also should do to your main DNS servers is to add the records (glue) to the registrar (child dns settings or similar) for ns2 and ns1 to their corresponding external IPs.
  3. Falrish

    Falrish New Member

    That is done. I have the glue records already in place. Just in the DiG it shows as the internal IP and not the external IP.
  4. linus

    linus Member

    So from the gui it shows the external ip for that host? And you have it mirrored to the slave? Have you set up debugging on the slave to see what it outputs when it tries to sync the values?

    You can check the /etc/bind/ file at both hosts to verify what bind has.
  5. Falrish

    Falrish New Member on the master server has the following:
    ns2 3600 A
    ns1 3600 A on the slave server has the following:
    ns1 3600 A
    ns2 3600 A

    Master Server: dig @localhost 3600 IN A 3600 IN A

    Slave Server: dig @ 3600 IN A 0 IN A

    Slave Server: dig @localhost 3600 IN A 3600 IN A

    strange outcomes...
  6. linus

    linus Member

  7. Falrish

    Falrish New Member

    Not unless ISPConfig 3.1.2 sets up the views. I will review all the /etc/bind files on both servers
  8. linus

    linus Member

  9. Falrish

    Falrish New Member

    it holds the outside IP there. I just find it strange. perhaps it is just a resolution as I am attempting to pull information internally to the local IP.

    This makes me feel better and gives me the ability to flip the switch on my new web server :)

    Thank you for the help.

Share This Page