Newbie q's

Discussion in 'Server Operation' started by Squidge, Dec 28, 2008.

  1. marpada

    marpada New Member

    Last edited: May 13, 2011
  2. Squidge

    Squidge New Member

    Thank you very much. Really sorry about asking all the questions. I am brand new to Unix. But am reading alot of stuff about it. So fingers crossed the questions will come to end soon :D

    Thanks again
     
  3. Squidge

    Squidge New Member

    i'm back again.

    I have installed the basic LAMP and SSH server software, configured the Network file to look like this:
    But i still cannot connect outside of my network. I have set up HTTP and FTP forwarding on my router, and have also set a new service for Webmin on my router as well. Could someone point out where i may be going wrong? Thank you in advance :(
     
  4. chipsafts

    chipsafts New Member

    if possible, take a printscreen of your router configuration for the http and webmin forwarding and post it here.

    And are you sure that the changes you made to the router have been applied ?
     
  5. Squidge

    Squidge New Member

    [​IMG]
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Your system cannot connect to the DNS servers 192.168.4.100 and 192.168.8.100 because they are in a different subnet. Please try 145.253.2.75 and 213.191.92.86 as nameservers.
     
  7. Squidge

    Squidge New Member

    none of the DNS nameserver worked, so i chopped them out and now have this:

    auto eth0
    iface eth0 inet static
    address 192.168.1.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.225
    gateway 192.168.1.1


    Which is letting me SSH to the server now, so thats good :)

    Only thing now is i am trying to set up ProFTPD but it keeps timing out when it trys to retrieve:

    Status: Server sent passive reply with unroutable address. Using server address instead.
    Command: LIST
    Error: Connection timed out
    Error: Failed to retrieve directory listing
     
    Last edited: Jan 6, 2009
  8. Squidge

    Squidge New Member

    Sorry got that sorted out. Newbie error.

    I am trying to set up postfix. all i want is to be able to send out email from a website. How do i do this?
     
  9. falko

    falko Super Moderator ISPConfig Developer

  10. Squidge

    Squidge New Member

  11. falko

    falko Super Moderator ISPConfig Developer

    Just replace server1.example.com with your own hostname.
     
  12. Squidge

    Squidge New Member

    I am stuck with this bit:

    Next we configure Postfix for TLS (make sure that you use the correct hostname for myhostname):

    postconf -e 'myhostname = server1.example.com'

    my server is "server1.yellow-zebra.co.uk"
    what do i use for <i>myhostname</i>

    also i have this:
    instead of what you have in the guide:
    Any help again would be greatly appreciated
     
    Last edited: Jan 7, 2009
  13. falko

    falko Super Moderator ISPConfig Developer

    server1.yellow-zebra.co.uk

    Sendmail is still running. Stop it and start Postfix.
     
  14. Squidge

    Squidge New Member

    Thanks very much for your help. I have now got it up and running. I had removed Sendmail but it left trace files behind so removed them, reinstalled postfix following your guide. And voila!!!! One work Server, with email capability!!!

    Thank you so much for your help :D
     
  15. Squidge

    Squidge New Member

    one last question, how do i enable apache to use clean urls?

    Not to worry, i have solved it :)
     
    Last edited: Jan 8, 2009
  16. Squidge

    Squidge New Member

    Me again.

    Everything is running fine bar one issue. When i send an email from my website, i get a file that creates itself in the /Maildir/new/

    Is there anyway of stopping this as they keep coming through
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Of what user? Are you sending to a foreign domain, or a domain that is hosted on your server?
     
  18. Squidge

    Squidge New Member

    Seems to have stopped now. It is in the /var/www/ as root
     
  19. falko

    falko Super Moderator ISPConfig Developer

    Ah, that's probably the mailbox of the user www-data (the Apache user on Debian/Ubuntu); mails from web applications are sent as this user. Maybe there were some bounces, that's why the Maildir got created.
     

Share This Page