Newbie Q - Websites won't display

Discussion in 'Installation/Configuration' started by caseygee, Jul 13, 2006.

  1. caseygee

    caseygee New Member


    I'm a newbie to both linux and ispconfig so i'm learning as i go so please bear with me. I've got ISPConfig running on Suse 10.1, i followed the perfect set-up how-to (very well written).

    I've set up a site on the server and created the DNS records. I can ping the domain name ( and i get a reply from my wan ip. But when i try to access through a browser, nothing displays, not even an error message, it just continues to load forever.

    Has anyone had a problem like this? It's most probably something really basic but i can't seem to find what is wrong. Any help would be greatly appreciated as it has me stumped.

    Many thanks in advance,

  2. freedog96150

    freedog96150 New Member

    We really need more information to properly troubleshoot your problem, but here are some ideas for a starting point in your troubleshooting.

    1. Is the ISPCONFIG server behind a seperate firewall or router?
    This sounds like the most likely scenario because a firewall/router would answer a ping for the public IP, but not forward packet if not configured. So, if this is the case, check your router/firewall and make sure that port 80 is forwarded to the internal IP for the web server. Remember that if you want to use other apps like SSH, FTP, Mail, DNS, etc through the firewall, they will all need the appropriate forwarded ports.

    2. Is the web server really online?
    In ISPConfig, goto Management->Server->Service tab and make sure that the webserver is online. Is so, can you load the website with the internal IP address? If you can load the website with the IP address, but not a name, then DNS is most likely your culprit.

    This should give you a good starting point.

  3. caseygee

    caseygee New Member

    Thanks Brian,

    All the services are online in the management > services, how would i go about testing the site with my internal IP? My server address is, but how will that find the site that i've created in ISPConfig? Do i need to edit the host file on my windows machine? If so what do i need to type in there?

    Many thanks

  4. jockstrap

    jockstrap New Member

    If you are testing real type domain names but on your internal ip range - update your windows hosts file with the domain and the internal ip so that when you type the name on your windows machine, it tries to surf your internal ip instead of the real domain name.


    hope this helps..
  5. falko

    falko Super Moderator ISPConfig Developer

    Have a look here: file windows

Share This Page