Newb: Need mail server settings (Roundcube installer driving me insane...)

Discussion in 'Installation/Configuration' started by Slowhand, Jun 10, 2009.

  1. Slowhand

    Slowhand New Member

    Hi,

    I'm on the final straight with my 'Perfect Server Ubuntu 8.04 LTS' server with ISPc3.

    I'm trying to install Roundcube.

    I get green lights everywhere but I can't get my mailserver settings right.

    If my server is called sierra.qwerty.com, please help me with the following:

    The Roundcube installer asks:
    Code:
    [I]default_host[/I]
        The IMAP host(s) chosen to perform the log-in?
    [I]To use SSL/IMAPS connection, type ssl://hostname[/I]
    
    ssl://sierra.qwerty.com? Doesn't seem to work...
    The port should be 143?

    also
    Code:
    [I]SMTP Settings[/I]
    
    smtp_server?
    
    [I]Use this host for sending mails
    
    To use SSL connection, set ssl://smtp.host.com[/I]
    
    ssl://smtp.sierra.qwerty.com?
    Doesn't seem to work...

    This is netstat -tap if it's useful...
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      5312/amavisd (maste
    tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      3961/master     
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      5386/mysqld     
    tcp        0      0 localhost.localdo:spamd *:*                     LISTEN      5450/spamd.pid  
    tcp        0      0 *:webcache              *:*                     LISTEN      22612/apache2   
    tcp        0      0 *:www                   *:*                     LISTEN      22612/apache2   
    tcp        0      0 *:ftp                   *:*                     LISTEN      5955/pure-ftpd (SER
    tcp        0      0 sierra.qwerty:domain *:*                     LISTEN      5876/mydns      
    tcp        0      0 localhost.locald:domain *:*                     LISTEN      5876/mydns      
    tcp        0      0 *:smtp                  *:*                     LISTEN      3961/master     
    tcp        0      0 *:https                 *:*                     LISTEN      22612/apache2   
    tcp        0      0 localhost.localdo:58110 localhost.localdoma:www TIME_WAIT   -               
    tcp        0      0 localhost.localdo:mysql localhost.localdo:36148 ESTABLISHED 5386/mysqld     
    tcp        0      0 localhost.localdo:47982 localhost.localdoma:ftp TIME_WAIT   -               
    tcp        0      0 localhost.localdo:36148 localhost.localdo:mysql ESTABLISHED 5410/amavisd (ch2-a
    tcp        1      0 localhost.localdo:49448 localhost.localdo:mysql CLOSE_WAIT  5411/amavisd (ch1-a
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      3884/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      5863/couriertcpd
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      5843/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      5804/couriertcpd
    tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      5955/pure-ftpd (SER
    tcp6       0      0 ip6-localhost:domain    [::]:*                  LISTEN      5876/mydns      
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      5278/sshd       
    tcp6       0      0 sierra.qwerty:ssh 192.168.0.6%31137:63020 ESTABLISHED 6488/sshd: slowhand
    tcp6       0      0 sierra.qwerty:ssh 192.168.0.6%31137:63176 ESTABLISHED 22747/sshd: slowhand
    
    The errors I'm getting are
    Code:
    Connecting to ssl://localhost...
    IMAP connect:  NOT OK(Authentication for slowhand failed (LOGIN): "a001 NO Login failed.")
    
    Test SMTP settings
    
    Server: ssl://localhost
    Port: 465
    User: (none)
    Password: (none)
    
    Trying to send email...
    SMTP send:  NOT OK(Connection failed: Failed to connect socket: Connection refused)
    I've tried a zillion variations on the host name...

    Thanks guys...

    S
     
    Last edited: Jun 10, 2009
  2. till

    till Super Moderator

    Make sure that you craete a dns A-Record for sierra.qwerty.com first on the dns server of the domain qwerty.com that points to the IP address of your server.
     
  3. Slowhand

    Slowhand New Member

    Till,

    But aren't the errors I'm getting more basic than that?

    I still don't know what my server addresses are for imap and smtp...?

    I can't even get past the installer.

    Don't I need to know whether my imap server is imap.qwerty.com, imaps.qwerty.com, mail.qwerty.com, imap.sierra.qwerty.com, imaps.sierra.qwerty.com...?

    ssl://, tsl:// ?

    Same for smtp and pop3

    Don't I need this info?

    S
     
    Last edited: Jun 10, 2009
  4. till

    till Super Moderator

    No. You can use any IP address or domain name that points to the server. So your problem is just as simple as you missed to create the dns A-Record.
     
  5. Slowhand

    Slowhand New Member

    Till,

    I can't help thinking we are talking at cross purposes...

    The server isn't facing the internet yet as I want to be sure it's perfect and secure before I make it a 'production server'. Hence I don't have a DNS record pointing at it.

    However, if I get an error like
    IMAP connect: NOT OK(Authentication for slowhand failed (LOGIN): "a001 NO Login failed.")

    Is that *really* a DNS issue?

    If the Roundcube installer asks me "what is your imap host server", surely I need to know the answer?

    No?

    Are you really saying that if I opened the server up to the internet and pointed an A record at it the error would go away?

    Edit: Imagine I wanted to mount the qwerty.com imap server in my OSX 'Mail App'. I wouldn't know what settings to use...?

    S

    S
     
    Last edited: Jun 10, 2009
  6. till

    till Super Moderator

    I posted this already above and here the answer again. You may use any IP address of your server or any domain name that points to the IP of your server as imap server. So what does this mean? Your server has the IP 123.123.123.123, then use 123.123.123.123 as Imap server. Or your server has the hostname server.mydomain.com that exists in dns and points to the IP 123.123.123.123 then use server.mydomain.com as imap server. If you use a domain that does not exist it will not work of course as your imap client is not able to connect to a non existant domain.

    And to your second error, you used the wrong login name. The login name for email accounts is the complete email address.
     
  7. Slowhand

    Slowhand New Member

    But I want to use the *local* imap server and don't know what the settings for it are.

    If the question from the Roundcube installer is:
    Code:
    default_host
        The IMAP host(s) chosen to perform the log-in?
    To use SSL/IMAPS connection, type ssl://hostname 
    and I want to use my *local* server as set up in your 'Perfect Server' tutorial, what would my answer be?

    ssl://sierra.qwerty.com? This doesn't seem to work.

    Similarly, what is my *local* smtp server?

    ssl://sierra.qwerty.com again? This doesn't seem to work either.

    I'm not talking about sending or receiving mail yet, just getting through the Roundube installer and using my local mailserver.


    Of course. Sorry...:eek:

    S
     
  8. till

    till Super Moderator

    It is quite funny why you ignore my answers and ask the same question again and again and again while it is answered already.

    You may use any IP or hostname that points to your server as pop3 and imap server. The domain sierra.qwerty.com does not work because you will have to create a dns record for it, explained above already.

    For roundcube you can also use localhost as imap and smtp hostname but for any external imap client see my answer above and the other answers in this thread.
     
  9. Slowhand

    Slowhand New Member

    Till,

    Perhaps the penny is dropping...

    Am I right in saying that both my smpt and imap servers should be
    ssl://sierra.qwerty.com but the Roundcube test is failing because I don't have a dns pointing at the server?

    Yes?

    S
     
  10. Slowhand

    Slowhand New Member

    Till,

    I don't mean to offend...

    I tried ssl://localhost as well and got an error.

    Is it the ports I'm getting wrong?

    S
     
  11. till

    till Super Moderator

    There is no need to use SSL on a localhost connection. Just connect without SSL.
     
  12. Slowhand

    Slowhand New Member

    Summary:

    Till,

    I really appreciate your patience :) I realise I'm shredding your nerves...

    Having had some sleep and time to mull this over I just want to summarise this unfortunate thread in case it helps any other newbs:

    Starting from the top again:
    Short answer:
    Long answer:
    Please tell me that's right so I can have another go at my install :)

    S
     

Share This Page