New to Linux - need help downloading ISPConfig

Discussion in 'Installation/Configuration' started by crpowell, Jul 13, 2007.

  1. crpowell

    crpowell New Member

    I'm new to Linux and command lines. I followed the instructions in the howto "The Perfect Server - Fedora 7" and have reached the point to install ISPConfig. But, I can't find instructions on how to download ISPConfig using a command line. Please help!
     
  2. Hans

    Hans Moderator Moderator HowtoForge Supporter ISPConfig Developer

  3. bluethunder82

    bluethunder82 New Member

    In order the download and get the program ready:

    1) Move to which ever directory you want to download to

    2) Type:
    wget http://easynews.dl.sourceforge.net/sourceforge/ispconfig/ISPConfig-2.2.xx.tar.gz

    Replacing XX with the latest stable release.

    3) Once the file has been downloaded type:
    tar -xvzf ISPConfig-2.2.xx.tar.gz

    this will uncompress the files

    4) Move into the directory and install.

    That should get you setup.

    Cheers
     
  4. anotherbigal

    anotherbigal New Member

    Yep. Thanks to advice I've downloaded and unzipped the file to a /download directory that I created specially. And yes, when I look, lo and behold ls /download/install_ispconfig/ reveals that there is a file called setup. Excellent.

    As I have never run anything like this before please, how do I actually install ISPConfig from the files I have got and what directory should I put the installation into, or does it do it 'all on its own'?

    BigAl
     
  5. edge

    edge Active Member Moderator HowtoForge Supporter

    Example shown below is with verion ISPConfig 2.2.15.

    1) go to the /tmp dir
    Code:
    cd /tmp
    2) download the file (with wget)
    Code:
    wget http://prdownloads.sourceforge.net/ispconfig/ISPConfig-2.2.15.tar.gz?download
    3) unpack the file
    Code:
    tar xvfz ISPConfig-2.2.15.tar.gz
    4) step into the directory that the ISPConfig-2.2.15.tar.gz is unpacked in
    Code:
    cd install_ispconfig
    5) run setup
    Code:
    ./setup
    ISPconfig will create all the needed directories.

    Make sure that you are root when doing all this.
    Login with your username, and type
    Code:
    su
    It will now ask for the root password.

    More info here: http://www.ispconfig.org/manual_installation.htm (scroll down about 1/2 a page, and you will see the install info)
     
    Last edited: Jul 23, 2007
  6. anotherbigal

    anotherbigal New Member

    Thank you Edge. That all worked perfectly.

    Only one thing though. At the final questions section I entered the host name as 'www' which I believe is ok - it shows that in the installation instructions you sent the link for - but, and here's my mistake I think, for the next question, 'Please enter the domain' I entered the name of my current website (xxxxxxxxxxx.com). That does not work of course as that is already being hosted by a commercial company. The problem is that I now cannot log in to my ISPConfig control panel. I presume that there is a configuration file somewhere where I can edit out my mistake and replace it with something else. Can you point me to where please, and does the 'something else have to be entirely fictitious or one that is registered. I have an unused (not hosted anywhere) .co.uk name that I could use if necessary.

    Sorry for being so stupid

    BigAl
     
  7. edge

    edge Active Member Moderator HowtoForge Supporter

    In your case (for now) leave the www part empty.
    When asked for the 'enter the domain' part, use the server IP (if on a LAN or behind a router use the local server IP)

    You can change all this later when you login on ISPconfig.
    To access ISPconfig (after using the IP setup), use http://IP:81 (or if you told ISPconfig to use https, use https://IP:81)

    An other option (if you did install it with the domain name) is to add the domain name to the hosts file of the PC that you are trying to access ISPconfig with.

    When adding the domain name in the HOSTS file, make sure that you set the correct IP of the server.
    (something like)
    Code:
    10.0.0.10 www.domainname.com
    The hosts file for a Windows PC can be found in c:\windows\system32\drivers\etc
     
    Last edited: Jul 24, 2007
  8. anotherbigal

    anotherbigal New Member

    Thank you Edge. That worked just fine (as you knew it would).

    Up and running now and studying the manual. Should have seen the installation instructions earlier.

    Big Al
     
  9. chez17

    chez17 New Member

    I am having the same problem in Ubuntu. Can someone tell me the command to get the file? I tried apt-get, didnt seem to work.
     
  10. edge

    edge Active Member Moderator HowtoForge Supporter

    maybe you need to install wget 1st?

    http://packages.ubuntu.com/dapper/web/wget
     
  11. chez17

    chez17 New Member

    I apologize, wget works. I thought that it wouldnt work because we are using a different distrobution. Thanks.
     

Share This Page