New to ISPConfig - Phpmyadmin - Error 404 Not Found

Discussion in 'Installation/Configuration' started by Benji, Nov 9, 2019 at 5:40 AM.

  1. Benji

    Benji New Member

    I know that MySQL is working because I was able to install a WordPress site from a package. However when I try to access Phpmyadmin I get a Not Found page. The URL in question is like this http:// myipaddress:8080 / phpmyadmin

    I'm running Apache, Ubuntu 18.04, on DigitalOcean
     
  2. recin

    recin Member

    Try accessing with only http:// myipaddress/phpmyadmin
     
  3. Benji

    Benji New Member

    This brings up a template page 404 not found, and in the URL it switches over to https. Could this be the reason? How would I force it to stay http?
     
  4. ahrasis

    ahrasis Well-Known Member

    Check your vhost for phpmyadmin. Try also accessing it via domain/phpmyadmin if it makes a difference.
     
  5. Benji

    Benji New Member

    I have tried accessing with domain in front of it, but that does not work. As far as vhost, I guess I'm not sure what to check on that. Please advise.
     
  6. ahrasis

    ahrasis Well-Known Member

    You need to check ispconfig.vhost if you are trying to access from 8080 port or in apps.vhost if you are accessing from 80 or 443 port. If that is checked, make sure you did install phpmyadmin as per the tutorial or the manual.
     
  7. Benji

    Benji New Member

    ispconfig.vhost uses 8080
    apps.vhost uses 8081

    I reconfigured phpmyadmin through this command dpkg-reconfigure phpmyadmin
    I also checked around other threads and there is one particular that got me stopped:

    "Is there a phpmyadmin.conf symlink in /etc/apache2/conf.d/ that points to /etc/phpmyadmin/apache.conf?"​

    On my server I do not have a conf.d folder at all.
     
  8. ahrasis

    ahrasis Well-Known Member

    Strange. If I am not mistaken, only nginx setup normally uses port 8081 for apps. Not sure about apache2 as I am not using it since 14.04, so may be you can wait for somebody else to assist on this.
     
  9. Benji

    Benji New Member

    What port does your use?
     
  10. Jesse Norell

    Jesse Norell Well-Known Member

    I'd guess that is for a centos system. On Ubuntu you should have something more like /etc/apache2/conf-enabled/phpmyadmin.conf (I don't have a ubuntu system to reference offhand, but that's what the debian buster tutorial creates).
     
  11. Jesse Norell

    Jesse Norell Well-Known Member

    For production, you want to go the other way - fix https, and make sure nobody can use http at all for phpmyadmin.
     
  12. Benji

    Benji New Member

    I can destroy the server and start over. Can someone recommend a good youtube tutorial or other tutorial that I can use to setup ISPConfig correctly on Digital Ocean?
     
  13. Steini86

    Steini86 Active Member

    On the top right of the page is a small white box, which says "Search ..." type in: "perfect server" and hit enter. Choose the Tutorial, which fits your system and wanted software.
     
  14. ahrasis

    ahrasis Well-Known Member

  15. Benji

    Benji New Member

    After reinstalling the server from the tutorial provided by @ahrasis, the same problem with phpmyadmin persisted. Then I ran into this post https://askubuntu.com/questions/55280/phpmyadmin-is-not-working-after-i-installed-it
    which said that you have to open and edit /etc/apache2/apache2.conf
    paste this at the end of the file Include /etc/phpmyadmin/apache.conf
    Restart Apache and Bingo!

    Secondly, after I logged in to phpmyadmin, I had Warning in ./libraries/plugin_interface.lib.php#551
    which was probably due to the fact that an older version of phpmyadmin was installed. But following these simple steps got my phpmyadmin updated and the Warning went away: https://devanswers.co/manually-upgrade-phpmyadmin/

    Anyways, thanks to all the guys who helped me.
     
  16. Jesse Norell

    Jesse Norell Well-Known Member

    Perhaps something is wrong with your base linux distribution, as those tutorials result in a functioning phpmyadmin if followed correctly. I've never used Digital Ocean, and don't know what you get with their images.

    From browsing the phpmyadmin.postinst script which comes in the phpmyadmin package you installed per that tutorial, the only reason I see why that would happen is if you did not select apache as the webserver when configuring the phpmyadmin package, or if the /usr/share/apache2/apache2-maintscript-helper script doesn't exist (which I can't verify for ubuntu 18). You can run "dpkg-reconfigure phpmyadmin" to choose apache, then "a2enconf phpmyadmin" if it didn't create the symlink in conf-enabled automatically.

    Replacing part of a package's files manually leaves a bit of a mess on the system, in my opinion. Another option would be what I did when upgrading stretch systems to buster, simply purge the phpmyadmin package completely, then follow the steps in the debian buster perfect server tutorial to install phpmyadmin manually. It should be the same in ubuntu as in debian, and has worked perfectly every time I have used it.
     
  17. Jesse Norell

    Jesse Norell Well-Known Member

    On further thought, the tutorial is well tested and known to work, so I suspect the issue is simply you did not select apache as the web server when configuring the phpmyadmin package, though it is possible that ubuntu packages are broken and you happen to be the first user to come across the issue (that does happen once in a while).
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    That's indeed the most likely reason, actually it was the case in all cases I investigated myself. The problem is that users think that they selected an option but indeed they just navigated to it without 'locking' the option with the space bar.
     

Share This Page