New site documentroot & PHP problem

Discussion in 'Installation/Configuration' started by vincentthe, Nov 10, 2006.

  1. vincentthe

    vincentthe New Member


    after following the perfect setup for ubuntu 6.06 LTS and installing ISPConfig I run into the following problem. When creating a new site there seems to be a problem with the documentroot (see Besides that, PHP is enabled in the panel, but it does not seem to work properly. I double checked the tutorial for all apache related settings, but that seems to be ok.

    Please advice
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If I open in a browser, i get domain not found. Thats a DNS problem and not a apache problem. Please make sure you have a correct DNS A-Record for pointing to the IP of your server.
  3. vincentthe

    vincentthe New Member

    That is really strange. According to the nameserver check from the dutch internet domain registry, the dns settings are ok. Using different lookup nameservers from different locations and providers do give me back the correct ip address for this domain. By the way, the DNS server for this domain is not on this server and functions correctly for a couple of hundred other domains.

    I get a directory listing in my browser for this domain with the following items:
    web3/ is a symlink on the server to web3. web3 contains 1 file: index.php which is not parsed by php.

    It seems to me that the documentroot setting is somehow messed up and is one level too high. However, even if this is the case, php still should work, which it doesn't :(
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server in a NAT enviroment behind a router?
  5. vincentthe

    vincentthe New Member

    No, the server is in a co-location area in Redbus Interhouse Amsterdam. The ip-addresses are public ( and I don't have any problems resolving the domain from my home location (ADSL-KPN), my university (Surfnet) and from two other co-location centers with different ISP's (Trueserver & WideXS). Furthermore, the Nameserver check from the sidn (dutch internet domain register organization) gives a positive result on this domain (as well as all other domains on the same DNS servers). I don't have a clue why the domain doesn't resolve for you.

    But nonetheless, the real question is, why is php not working, and why is the documentroot (or at least that's my hunch) not set properly?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Sure, and thats why I asked the question above.

    Please double check that the IP you selected for the website in ISPConfig is identical with the IP where your domain resolves to. Also amke sure that the Vhost_ispconfig.conf file is included at the end of your apache configuration file. Are there copies of the file Vhost_ispconfig.conf in the same directory with a data appended to the filename? Do you have errors in the fole /home/admispconfig/ispconfig/ispconfig.log ?
  7. vincentthe

    vincentthe New Member

    Ok, that solved the problem :)

    The ip the domain resolved to is .201, and somehow I selected .202 in the interface.

    For the record, there were no errors in the log file. And there are no other copies of the Vhosts_ispconfig.conf in /etc/apache2/vhosts

Share This Page