new setup can not send or receive emails

Discussion in 'General' started by sygram, Feb 18, 2008.

  1. sygram

    sygram Member

    Hi there,

    i have setup a Centos 5 system (using perfect setup) with latest version of ispconfig.

    Everything went smoothly.

    The only problem is that i can not send or receive emails :

    When i send an email to an email address hosted at this domain i get this response :

    <[email protected]>:
    11.11.11.119 does not like recipient.
    Remote host said: 554 5.7.1 <[email protected]>: Relay access denied
    Giving up on 11.11.11.119.

    Also i tried to send using phpmailer but the email is not delivered. ...

    Does anyone has any idea how to fix this ?

    Thank you very much. Your answers are appreciated.

    Regards,

    Leon
     
  2. sygram

    sygram Member

    Sorry for the above info. I think i can send emails. The problem is in receiving them.

    It might have to do something with Maildir ?

    Thanks

    Leon
     
  3. sygram

    sygram Member

    Guys i think i have discovered a bug.

    Ispconfig allows you to "rename" a domain. i.e. from test.com to test2.com and this is what i did.

    Although most of the features are updated fine i.e. apache virtualhosts file, the local-host-domains and virtuser files of postfix keep the previous domain setting, thus the emails are not delivered correctly.

    I had to remove the website and create it from scratch in order to have all the files correctly. After that for some reason i started getting many emails and my postfix started sending emails in a loop. I removed all the accounts and deleted everything inside /var/spool/postfix... i.e. active folder.

    At this moment i think everything is working as it should but guys it was a nasty problem and i am happy that is solved (at least i think).

    I think the developers should look into the "renaming" case. Safest option would be after you insert a domain not to be able to change it i.e. with a non editable field.

    Best Regards,

    Leonidas
     
  4. falko

    falko Super Moderator ISPConfig Developer

    We'll check this.
     

Share This Page