New server with Debian 10 and Let's Encrypt

Discussion in 'Installation/Configuration' started by Bocki, Mar 2, 2020.

  1. Bocki

    Bocki New Member HowtoForge Supporter

    Hi everybody,
    I've just setup a new server as described in the perfect server tutorial with Debian 10, Apache, Bind, Dovecot. I installed Let's Encrypt client, without error message.
    Now I tried to configure my first domain and activated SSL and Let's Encrypt SSL but unfortunately no cert is being requested. As is, there is not even a directory /etc/letsencrypt created or some logging in /var/log/letsencrypt (directory does not exist). How can I check whether the installed client (I can see it in /opt/eff.org) basically works and what stops it from requesting a cert?
    Thanks in advance!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Bocki

    Bocki New Member HowtoForge Supporter

    Thanks for this super fast reply!
    Yes, I did run "certbot-auto --install-only".
    Now I followed your advice in the FAQ and it helped: I switched "Skip Letsencrypt check" under System > Server config > web to "enabled" and now it works.
    Thanks again, your support is outstanding! :)
     
    till likes this.

Share This Page