New Multiple PHP Versions tutorials request

Discussion in 'ISPConfig 3 Priority Support' started by budgierless, Sep 8, 2015.

  1. budgierless

    budgierless Member HowtoForge Supporter


    I have used the tutorials for multiple php versions with my ispconfig 3 on Ubuntu 12.04 LTS, and this is good, but i wanted to use this with a newer Ubuntu version such as 14.04+, but the tutorials stopped for this purpose and i was not sure why, so I did some research and found that since Ubuntu 14.04 Apache is version 2.4 which dose not work below php 5.4, so i am guessing this is the reason no more tutorials of this kind are being made?
    If so, I understand this, but also the last multiple php tutorial is a few years old, and their must be a way to work around this issue, but i have only found bits and pieces, but some people say they managed to get Apache 2.4 to work with php 5.3.
    I am not a programmer and i only understand a little about ispconfig code, but I have found good information that can be used to make a updated tutorial, please have a look at the links and tell me if you think you have what information you need to do this, because i would like to upgrade Ubuntu while still able to use php 5.3, and i am sure other members would like this information for Ubuntu 14.04+ and a likes also maybe this can be added to the next ispconfig 3.1 release if needed too.

    Below are 3 web-links that help.
    A member said he got ubuntu 14.04 ispconfig and php5.3 working with these with

    kind regards
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use all php versions with apache 2.4 as well, there are no restrictions for php-fcgi regarding the apache version. The php compile installation steps are the same for current ubuntu versions and I still use the existing Debian and Ubuntu tutorials for them, there are no changes in ispconfig required. It is possible that a php module or switch is not available anymore, so just leave that out then.

    I'll try to test the guides and save them under a new name so that it's clear that you can still use them.
  3. budgierless

    budgierless Member HowtoForge Supporter

    Are you sure? because I read online that PHP 5.2 and 5.3 are incompatible Apache 2.4 as native install but may work if Apache is compiled from source because of a header issue.
    I maybe wrong but is that is true then I guessed it would also be the same issue for vhost versions?
    I also know that php5.2 dose not support fpm but dose work with as mod-php because i use that with Apache 2.2.

    what Apache version are you using? and was it compile or a native install?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You might mix up mod_php and php-fcgi here. The additional php versions are always fcgi or fpm and they don't get compiled against apache.

    For php 5.2 you use fcgi in a multi php setup. mod_php should not be used anymore for security reasons.

    The stock apache versions of the OS installed with apt, no manually compiled apache.
  5. budgierless

    budgierless Member HowtoForge Supporter

    Very interesting, but why is their fixes in the web links i posted, if their is no issue or no need?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The links above contain just the usual php compile instructions, no fixes and nothing special. Howtoforge has no monopoly on instructions to compile php, other sites are free to post the same steps. Phpfarm is just a shell script that contains the usual configure statement. If you use their instructions or the ones from does not matter as the result will always be a php fcgi binary that you can use on your server.
  7. budgierless

    budgierless Member HowtoForge Supporter

    that's fine thanks, Can I ask you to check if the ./configure settings have to changed for php 7.0?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    There is a compile tutorial for php 7 on Debian, this should work for ubuntu as well.

Share This Page