new mail box - send copy to (optional) not working

Discussion in 'General' started by pawan, Apr 12, 2011.

  1. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    changed from 2 -> 5 MB

    Thank you! Changed quota and still get same error.

    At the same time that sender gets message above, root on the server gets this mail:

    The "support" mailbox is the address in the Send copy to field and the support entry in /etc/aliases I have commented out.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  3. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    Thanks. It seems to be looking for a system user, but I don't know why? Unless it's because of the STARTTLS failure in line 5 (I added numbers and spaces between lines).
    Not sure why that line is from sendmail, which is stopped. In this example user allen is not and never was a system user, only defined as virtual user.

    Immediately following we get "User unknown in local recipient table" from Postfix, then same thing in line 7 again from sendmail.

    In line 8 it sends the message to root, which I do get as displayed above.

    I am familiar with sendmail but not so much with Postfix and Maildrop, but I'm learning. Thanks for your help!!!
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    That is strange. Can you post the output of
    Code:
    netstat -tap
    ?
     
  5. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    problem limited to server domain only

    Yes, thank you, here it is
    Code:
    tcp        0      0 localhost:10024             *:*                         LISTEN      1471/amavisd (maste 
    tcp        0      0 localhost:10025             *:*                         LISTEN      1650/master         
    tcp        0      0 *:mysql                     *:*                         LISTEN      1398/mysqld         
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1000/rpcbind        
    tcp        0      0 *:53170                     *:*                         LISTEN      1051/rpc.statd      
    tcp        0      0 *:ftp                       *:*                         LISTEN      1659/pure-ftpd (SER 
    tcp        0      0 ns01.mydomain:domain *:*                         LISTEN      1056/named          
    tcp        0      0 localhost:domain            *:*                         LISTEN      1056/named          
    tcp        0      0 *:ssh                       *:*                         LISTEN      1156/sshd           
    tcp        0      0 *:smtp                      *:*                         LISTEN      1650/master         
    tcp        0      0 localhost:rndc              *:*                         LISTEN      1056/named          
    tcp        0      0 ns01.mydomain.co:ssh 192.168.1.100:umsp          ESTABLISHED 3793/sshd: root@pts 
    tcp        0      0 localhost:48469             localhost:mysql             ESTABLISHED 1678/amavisd (ch11- 
    tcp        0      0 localhost:48483             localhost:mysql             ESTABLISHED 1679/amavisd (ch10- 
    tcp        0      0 localhost:mysql             localhost:48483             ESTABLISHED 1398/mysqld         
    tcp        0      0 ns01.mydomain.co:ssh 192.168.1.102:41087         ESTABLISHED 4377/sshd: root@pts 
    tcp        0      0 localhost:mysql             localhost:48469             ESTABLISHED 1398/mysqld         
    tcp        0      0 *:https                     *:*                         LISTEN      1607/httpd          
    tcp        0      0 *:imaps                     *:*                         LISTEN      1515/couriertcpd    
    tcp        0      0 *:pop3s                     *:*                         LISTEN      1551/couriertcpd    
    tcp        0      0 *:52778                     *:*                         LISTEN      1051/rpc.statd      
    tcp        0      0 *:pop3                      *:*                         LISTEN      1540/couriertcpd    
    tcp        0      0 *:imap                      *:*                         LISTEN      1506/couriertcpd    
    tcp        0      0 *:sunrpc                    *:*                         LISTEN      1000/rpcbind        
    tcp        0      0 *:webcache                  *:*                         LISTEN      1607/httpd          
    tcp        0      0 *:http                      *:*                         LISTEN      1607/httpd          
    tcp        0      0 *:tproxy                    *:*                         LISTEN      1607/httpd          
    tcp        0      0 *:ftp                       *:*                         LISTEN      1659/pure-ftpd (SER 
    tcp        0      0 *:ssh                       *:*                         LISTEN      1156/sshd           
    tcp        0      0 *:smtp                      *:*                         LISTEN      1650/master         
    tcp        0      0 localhost:rndc              *:*                         LISTEN      1056/named    
    
    The problem I'm having is with mydomain.com which is the same domain name as in the FQDN of my server, i.e. ns01.mydomain.com. Apparently this is the only domain for which the Send copy to field isn't working.

    I tried using the Send copy to field in someotherdomain.com and it worked fine! So the problem doesn't affect customers but only me. However its a nice feature and I'd like to use it.

    Thanks again.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Is the fqdn of your server mydomain.com or ns1.mydomain.com? That makes a big difference, as postfix threats mydomain.com and ns1.mydomain.com as different domains, so no problems should occur.

    Please post the output of:

    grep mydomain.com /etc/postfix/main.cf

    to see if mydomain.com is used anywhere in that file instead of ns1.mydomain.com
     
  7. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    synonym in /etc/hosts

    Problem was a synonym in /etc/hosts.

    Thanks!!!:)
     

Share This Page