new mail box - send copy to (optional) not working

Discussion in 'General' started by pawan, Apr 12, 2011.

  1. pawan

    pawan Member

    I have been using ISPCONFIG 3 since quite some time, but on creaing new email box whenever I feel this field - Send copy to --------------------(optional) doesn't seems to be working.

    Any solutions please.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The filed is working on update and not insert. So when you fill in the email address after you first saved the mailbox, then it will work. This has been fixed in SVN already and will be released with ispconfig 3.0.3.3.
     
  3. matiasCU

    matiasCU New Member

    Hi guys anyone has been able to determine why this is wrong? I have installed ISPConfig Version: 3.0.3.3 but not from svn and do not work either.
    Messages arrive at the destination mailbox, but not to the account specified in the field send copy to

    Best regards.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This fix works only for new accounts and not existing accounts. For existing accounts, remove the email from the send copy to field, click save, enter the address again and click save again.
     
  6. matiasCU

    matiasCU New Member

    As always thank you very much Till, you're right, the problem is solved.
     
  7. dar_ek

    dar_ek New Member

    Are you sure that was fixed?
    I'd upgrade 3.0.3 to 3.0.3.3 and still it isnt work.

    (But bugtrack ticket is closed FS#1561).

    Whitch file I must check for that fix?

    Edit: I'd check in svn, and this is file maildrop_plugin.inc.php, and only change one line (add):

    [rev. 2279]

    This is enough?
    Till check this again, plz.
     
    Last edited: May 31, 2011
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    It works on my servers, I just tested it. Dont forget that you have to empty the field, click on save and then insert the email address again if the address was entered before you updated to 3.0.3.3

    Yes, thats was the missing code.
     
  9. dar_ek

    dar_ek New Member

    I dont get it.

    I know - update "Send copy to" field is (and was) working.

    But in my 3.0.3.3 I create ADD NEW MAILBOX with filed "Send copy to", and nothing happens. I dont have new file /var/vmail/mailfilters/DOMAIN/USER/.mailfilter

    (3.0.3.3 upgraded from 3.0.3, and two ISPConfig patched manually "maildrop_plugin.inc.php")

    strange, what may I debug it?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you normally update or did you patch only one file? The patches in 3.0.3.3 depend on patches in 3.0.3.2 and so on. So to get a working system, its not enough to copy or patch only one file manually, you have to update your server to 3.0.3.3 with the ispconfig update.php script to get all patches applied.
     
  11. dar_ek

    dar_ek New Member

    I checked code ones again.

    You have a BUG in this line (svn, and v3.0.3.3) maildrop_plugin.inc.php:

    It must be that:

    probably altered it manually and exchange a "insert/update" in this two params.

    Check it, and repair ISPConfig, plz.

    ps. I wonder how it is possible that it works for you ... :)
     
    Last edited: May 31, 2011
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    You are right. The file that i have on my test system has this already patched, seems that I missed to submit it to SVN again.
     
  13. RedGerry

    RedGerry New Member

    Sorry I can't get access to the SVN. I have a working system with the latest release and can't get this forwarding option to work despite the guidance from posts above.

    In the maildrop.plugin.inc.php file I have three lines after the /* Register for the events */ tag They are all:

    $app->plugins... etc.

    Can someone post here what these 3 lines should be exactly so I can amend the file manually and get this feature working. My users are moaning.... :rolleyes:
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

  15. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    still have this problem

    I have installed and am running 3.0.3.3 and have made this change in maildrop_plugin.inc.php:

    I also removed the contents of Send copy to and re-entered address and still not working.

    Does something have to be rebuilt. I know, I'm such a newbie.
     
    Last edited: Oct 13, 2011
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Which imap server do you use? Courier or dovecot?
     
  17. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    Followed Fedora 15 Perfect Server Howto

    Thank you!

    Following the Howto I've installed Courier.

    Messaged returned to my sending account is:
    Can you tell what I've done wrong this time. Thanks again.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Please set a higher quota for this mailbox in ispconfig and click on save.
    2) is mydomain.com the hostname of this server?
     
  19. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    Quota was set at /var/www/ level

    1) Maybe it should be set at /var instead.

    I have another Fedora system with all space allocated under / (root) and it has had space problems, so on this one made /var /var/www separate mount points.

    I installed Quota in /var/www. Is that the issue? If so can it be changed now?

    2) The hostname is ns01.mydomain.com.
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    1) You mix up mail quota with filesystem qupota here. Mailquota is a virtual quota inide the imap daemon. Please change the quota value in ISPConfig as I suggested.

    2) ok.
     

Share This Page