New ISPConfig module for WHMCS

Discussion in 'Tips/Tricks/Mods' started by cwispy, Dec 11, 2014.

  1. Ho2x

    Ho2x New Member

    Hello, is it possible to update elFinder?
    Thank's
     
  2. cwispy

    cwispy Active Member

    I will add it to the list of things to do.
     
    budgierless likes this.
  3. jackserippl

    jackserippl New Member

    Hi
    I have installed the module and see that in client area navigating through the Menu (Databases, DNS, Corn, etc.) the first 3 klicks are really fast, but then everything slows down. Waiting on the new window about a minute or two, but works. If I clear browser cache and re-login everthing is fast till the next 3 klicks. Does anybody have an idea where the Problem could be?
    I do not have any errors in the logs, do not find a loop or any strange behavieur. Working with WHMCS v7.8.3
    Very thankful for any push to the right direction :)
     
  4. ironjohn

    ironjohn New Member HowtoForge Supporter

    Hi guys,
    I've been working my way through this and hit a snag that is beyond me. When I accept an order in WHMCS I get the error "No ISPConfig Limit-Template Match Found".
    I can curl from localhost and a remote ubuntu just fine. All the details of my one and only limit template are returned in console. template_id = 1
    I do not have SSH access to this remote WHMCS server, so cannot curl directly from it.
    URL matches perfectly in ispcfg3.

    Any help would be greatly appreciated!
    -John
     
  5. ironjohn

    ironjohn New Member HowtoForge Supporter

    Mia Culpa! :D

    It was a Username typo in the ISPConfig INtegration Module setup. Test Connection would always pass, so I didn't suspect it.

    A few minutes ago it hit me that I don't need shh on the whmcs server because they have a debug log option.

    The log showed a failed login response from ISPConfig. I wasted a few minutes checking cwispy's code for a difference between Test Connection and CreateClient login.

    It didn't take long for me to remember that the last update was weeks ago and I'm the only one with a problem. Sure enough the user ID i tested with in curl was not the same as I typed in the Password field for Test Connection. I copied and pasted from my curl notes and it works perfectly.

    I don't know why the module is passing if ( $response == TRUE ) when ISPConfig returns a failure. If I knew more I would help.

    Thanks cwispy for all the work you have done!
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Note: total guess here, I have not referred to the code you're referencing. :)

    Probably the rest (soap?) call succeeded, ie. it sent a request and got back a valid response, probably with a 200 http response code. You have to interpret the contents of the response to see if there is an error or not. (as a working example, see the apiCall function from the csv import script at https://www.howtoforge.com/community/threads/import-email-accounts-from-csv.82524/)
     
    Last edited: Nov 13, 2019
  7. ironjohn

    ironjohn New Member HowtoForge Supporter

    It's a pretty clear response:

    {"code":"remote_fault","message":"The login failed. Username or password wrong.","response":false}
     
  8. ironjohn

    ironjohn New Member HowtoForge Supporter

    Wait, I red your post again. Now I get it. You are correct. The next log entry is "true", but that's one server saying "got it buddy" to the other.
     
  9. elmacus

    elmacus Active Member HowtoForge Supporter

    Hi, im testing this now with latest code from https://github.com/cwispy/ispcfg3 , not https://marketplace.whmcs.com/product/2214. EDIT, seems that its the same versions, ie downloads from github.
    I will add more findings to this post, read it again.

    Some problems i have in WHCMS, just a few until i stopped, could be more:
    1. Cant create "Emails" at all. Button is there and Green, but cant press it.

    2. When manually adding new "Email account" in ISPconfig, it will be imported in WHCMS automatically and some other custumers account, so there is big security problem.
    Since i cant find a simple way to disconnect the wrong email-account, this is a showblocker right now.

    3. Editing DNS-records is not possible, DNS Zone is missing, and cant be choosen. Error message: Zone is required

    4. Secondary DNS is not added, i have to add it manually. I can live with this, but really needed.

    5. PHP for Website is Disabled in ISPconfig, must activate manually. I can live with this.
    5.1. Cant change PHP-version in websites in WHCMS.

    6. Spamfilter should be "normal" at start, not "disabled". I can live with this.

    7. Multiserver (every server has all services), adding second server www2, when creating custumer on www2 server, website is created there ok, but email is created on www1 server. WWW1 server is not active in Group.
    Webmail link also points to wrong server.

    8. Is my Client-Template read at all ? i only got 1 with id =1. Template got both www1 and www2.
    9. Every limit lists as: ( 1 of ) or ( 0 of ).

    Anyone with insight, please try this to add email account and change DNS and report.
    WHCMS 7.8.3, ISPConfig 3.1.15p2. Debian 10.2.
     
    Last edited: Nov 28, 2019
  10. nokia80

    nokia80 Member

    Hi @cwispy

    Thanks fore your great work.

    I only have 1 question how is it possible that when a customer presses on emails he sees all the mail account on the server?

    hope we can solve this
     
  11. nokia80

    nokia80 Member

    Hi All,
    is this project dead?
    Have someone a other solutions?
     
  12. Ho2x

    Ho2x New Member

    Not dead
     
  13. nokia80

    nokia80 Member

  14. Ho2x

    Ho2x New Member

    This is an open source project. Cwispy is busy. If you want speed you can watch the whmcs ispconfig paid script.
     
  15. nokia80

    nokia80 Member

    Where ? is the paid script?
     
  16. Ho2x

    Ho2x New Member

    I seem to have found it at the time. maybe this no longer exists.
     
  17. Ho2x

    Ho2x New Member

    cwispy generally updates every 6 months from what I've noticed. so don't panic :)
     
  18. Entangled

    Entangled Member

    Hello, I was wondering the same thing: is this plugin EOL (dead)? Someone mentioned a commercial (paid) version of this WHMCS plugin, where can I learn more about it and purchase it? Is crispy the only person responsible for updates? Thanks.
     
  19. Ho2x

    Ho2x New Member

    to my knowing yes it just has cwispy updating. the paid version it seemed to me that there was one but maybe not. otherwise I have been following the project for almost 2 years and cwispy does not quickly update the script. but he didn’t die.
     
  20. felan

    felan Member HowtoForge Supporter

    I personally would support a payed whmcs plugin and I have even approached cwispy to her if he want to support us with some issues for a fee, but I haven't heard back from him on it, sadly. His work is quite good otherwise.
     

Share This Page