New ISPConfig module for WHMCS

Discussion in 'Tips/Tricks/Mods' started by cwispy, Dec 11, 2014.

  1. octa.ci

    octa.ci New Member

    cwipsy, BenM thank you for solving the {IP} issue it works now as expected. But in my case the e-mail issue is not solved, it behaves differently now, if no e-mails are available it shows 0, but if you create an e-mail (from whmcs) it creates but afterwards the page shows the errors as on the screenshot:
    screenshot 2018-01-21 001.png
    the same error if to create the e-mail directly from ispcfg.
    Also I have a question is it possible to edit the links on bottom left corner: Website statistics, Webmail and phpMyadmin?
    Thank you.
     
  2. BenM

    BenM Member

    maybe you can use the previous version for the e-mail?

    I have looked at the links for o.a. login to ispconfig ect, but this is not easy to get through. Personally, I would like to have the functions, but then from the server instead of the domain name. server / webmail server / stats ect

    Maybe that cwipsy can work on that.
     
  3. cwispy

    cwispy Active Member

    Just edit views/login.php to modify the urls.

    elseif ($_GET['view_action'] == 'webmail') {
    header('Location: '.$domain_url.'/webmail/');
    exit;
    }
    elseif ($_GET['view_action'] == 'phpmyadmin') {
    header('Location: '.$domain_url.'/phpmyadmin/');
    exit;
    }
     
  4. cwispy

    cwispy Active Member

    Did you update all the files or just download a few changed files?
     
  5. octa.ci

    octa.ci New Member

    I have downloaded only modified files that you mentioned a few posts ago. Should I change all of them?
     
  6. cwispy

    cwispy Active Member

    Yes it would be worth a try.
     
  7. BenM

    BenM Member

    strange, this $return is empty, any idea?

    if (isset($_GET['view_action'])) {
    if ($_GET['view_action'] == 'ispconfig') {
    $return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $domain_url));
    //$return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $server_url));
    logModuleCall('ispconfig','Forwardispconfig',$return );

    }
    elseif ($_GET['view_action'] == 'stats') {
    $return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $domain_url));
    //$return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $server_url));
    }
    elseif ($_GET['view_action'] == 'webmail') {
    header('Location: '.$server_url.'/webmail/');
    exit;
    }
    elseif ($_GET['view_action'] == 'phpmyadmin') {
    header('Location: '.$server_url.'/phpmyadmin/');
    exit;
    }
    }
     
  8. cwispy

    cwispy Active Member

    For which one?
     
  9. BenM

    BenM Member

    for the forward to ispconfig

    if (isset($_GET['view_action'])) {
    if ($_GET['view_action'] == 'ispconfig') {
    $return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $domain_url));
    //$return = array('status' => 'success', 'ajax' => 'false', 'response' => array('server_url' => $server_url));
    logModuleCall('ispconfig','Forwardispconfig',$return );

    }
     
  10. BenM

    BenM Member

    array serverl_url is empty
     
  11. cwispy

    cwispy Active Member

    I have removed that link from the latest commit a couple of days ago. You need to update your hooks.php file.
     
  12. BenM

    BenM Member

    Hi CWISPY,

    Sorry but i want to use the button on the side bar, if i can?
    just wondering if i can understand the way you set it up.
    Are you willing to inform me?
    Or has the old structure never worked well?
     
  13. cwispy

    cwispy Active Member

    It was never implemented. It was put on there, but like the stats and phpmyadmin links, they have never been looked at. I dont think they need to be there really.
     
  14. BenM

    BenM Member

    okay thats clear.
     
  15. octa.ci

    octa.ci New Member

    Sorry for the late reply, I have updated all the files, still the same error
     
  16. Jmlz

    Jmlz New Member

    I have exactly the same issues and never found the solution. I think there is a problem somewhere on cookies or cache. I tryed to uninstall Xcache, there is the same issues.
    Someone can help ?
     
  17. Nico14

    Nico14 New Member

    Very good job.
    You said you will permit to setup product tool button. Can do it ?
    if my ispconfig server has an ip nat, the filemanager does not work? In this case, which ip should I put in the server configuration?

    Nico
     
  18. dawidryba

    dawidryba New Member

    Welcome.
    First... sory for my bad English.

    WHMCS 7.4.2 + ipscfg3 - Error 500 PHP 7.0
    I have problem with WHMCS 7.4.2 installed on Directadmin with PHP 7.0 FPM.
    I uploaded ispcfg3-master to modules/servers and rename folder ispcfg3.
    When i want to go add server on address configservers.php?action=manage i got error 500.
    If i delete ispcfg3 from modules/servers then error 500 gone.

    I tried find logs in httpd error_log and vhost domain error_log but this anomaly isn't save in this files.

    Thanks you for reply.
     
  19. cwispy

    cwispy Active Member

    Do you have the php soap modules installed?
     
  20. cwispy

    cwispy Active Member

    What do you mean by setup product setup button? I know I mentioned that it was something I may look at in the future, but its not something I am looking to do any time soon.
     

Share This Page