New ISPConfig module for WHMCS

Discussion in 'Tips/Tricks/Mods' started by cwispy, Dec 11, 2014.

  1. diablo666

    diablo666 Active Member HowtoForge Supporter

    But for example if i've 2 server ns1.domain.tld and ns2.domain.tld, i can't choose for example to activate
    - webserver, ftp, and other services on ns1.domain.tld
    - mail on ns2.domain.tld
    I'm missing something?
     
  2. cwispy

    cwispy Active Member

    In your last message you said you had a server for web and a server for mail. As such, the module will activate web and ftp on the web server and email on the mail server.
     
  3. diablo666

    diablo666 Active Member HowtoForge Supporter

    Ah ok, i've understand.
    The problem is that i've activated all modules on both server.
    So if i'll activate only web and ftp on one server, and only mail automatically the module will activate the correct services on both server right?
     
  4. cwispy

    cwispy Active Member

    Yes that is right. The module looks up the services in ispconfig and uses them to determine which server to use for what. In the event there are two servers with the same service, it will choose the server with the least number of sites.
     
  5. diablo666

    diablo666 Active Member HowtoForge Supporter

    OK perfect.
    You made a great work ;)
     
  6. diablo666

    diablo666 Active Member HowtoForge Supporter

    One last thing: there is a way to sync user in ispconfig with user on whmcs?
    For example setting up same user names?
     
  7. alex_xwire

    alex_xwire New Member

    Hey cwispy, great module. I also had the commercial one and this works perfect.
    Just a couple of things, has anybody tested this with WHMCS v6 yet?

    Many thanks,
    Alex
     
  8. cwispy

    cwispy Active Member

    Hi Alex,

    Yes I have tested the module with WHMCS v6 and it works fine.

    cwispy
     
  9. alex_xwire

    alex_xwire New Member

    Excellent thank you.

    Just a suggestion - a customer purchases a web hosting package that includes two websites could it be possible that your module can handle the creation of the second site via WHMCS?

    Many thanks,
    Alex
     
  10. cwispy

    cwispy Active Member

    Hi Alex,

    In its current form, the module has to setup 1 ISPConfig account per service. With the release of the next major version of ISPConfig, I should be able to change this behaviour to be able to create extra services under the same ISPConfig account.

    cwispy
     
  11. diablo666

    diablo666 Active Member HowtoForge Supporter

  12. alex_xwire

    alex_xwire New Member

    Wiked! :)
    Will keep an eye out.

    Thanks,
    Alex
     
  13. cwispy

    cwispy Active Member

    I just wanted to say thank you to all of you who have said kind things about this module and a special thank you to everyone who has made a donation to me. It is your words of gratitude and thank you by way of donations that makes things like this module rewarding.
     
    alex_xwire and budgierless like this.
  14. orfi

    orfi New Member

    hi
    i was happy to find this excellent project and finally i managed to install all the elements into a deb 7 32 bit ( whmcs + ispconfig3) but it`s not working yet .
    any step by step setup somewhere ??

    i got the error : SOAP Error: customer_no_error_unique<br /> when i want to accept the order .

    -----------------------------------------------------------------------------
     
  15. diablo666

    diablo666 Active Member HowtoForge Supporter

    Have you added the remote user to ispconfig?
     
    orfi likes this.
  16. webguyz

    webguyz Active Member HowtoForge Supporter

    Check the ispconfig clients to see if that name was already added. When I was starting out and doing a lot of testing I would see that error a lot because it had added the ispconfig info so fast I did not realize it. The wiki is a best source of info and details step-by-step what to do. That url is somewhere in this thread.
     
  17. budgierless

    budgierless Member HowtoForge Supporter

  18. orfi

    orfi New Member

    yes , and i checked for that specific issue, did the template , did the remote user, the ip is x.x.x.x:8080 and checked ssl, the error is still there when the command create is issued .
     
  19. orfi

    orfi New Member

    btw , at first connection i`m expecting a sync of the clients or we have to force this in some way ?
     
  20. orfi

    orfi New Member

    when we start working with the module how we make a sync to get all the clients in whmcs ?
     

Share This Page