New ISPConfig install not working at all

Discussion in 'Installation/Configuration' started by Scieri, Feb 19, 2015.

  1. Scieri

    Scieri New Member

    Hello to all members,

    I have a new server with debian 7, apache2, php5, even an wordpress site hosted. I've followed the tutorial for installing ISPConfig, all went ok, except when I'm accessing IP:8080, all I got was 403 forbidden, in apache logs I get: client denied by server configuration: /var/www/
    which is strange because the www directory is the web base directory but ispconfig is installed in /usr/local/ispconfig/interface/web which is accessed through an link from /var/www/ispconfig. My thought is that ISPConfig is not setting the correct path to it into the apache conf.
    In apache the vhost for 8080 doesn't have an document root set, if I set it to /var/www/ispconfig I get in error log: client denied by server configuration: /var/www/ispconfig/
    Bellow is the vhost file content:
    ServerAdmin [email protected]
    <FilesMatch "\.ph(p3?|tml)$">
    SetHandler None
    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    <FilesMatch "\.php$">
    SetHandler fcgid-script
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    IPCCommTimeout 7200
    MaxRequestLen 15728640

    <IfModule mpm_itk_module>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AssignUserId ispconfig ispconfig
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
    # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
    Options +FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    php_value magic_quotes_gpc 0

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    <IfModule mod_security2.c>
    SecRuleEngine Off

    # SSL Configuration
    SSLEngine On
    SSLProtocol All -SSLv2 -SSLv3
    SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    DocumentRoot /var/www/ispconfig
    #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

    Tweaking vhost to allow permission, takes the issue further to just displaying the php code and not running it. Even if the php is active and used on the existing wordpress site.

    Any ideas?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you did not install all required packages. At least mod_fcgi is missing, but maybe others as well. To get a working system:

    1) Install all packages that are descibed in this tutorial: Follow the guide to the letter to ensure that all is setup correctly.
    2) uninstall ispconfig by using the uninstall.php script to ensure that all your manual modifications are removed.
    3) install ispconfig again.

Share This Page