New ISPConfig install - debian10 apache error

Discussion in 'ISPConfig 3 Priority Support' started by anandx, May 10, 2020.

  1. anandx

    anandx Member HowtoForge Supporter

    Hi,

    I followed the guide
    Code:
    https://www.howtoforge.com/perfect-server-debian-10-buster-apache-bind-dovecot-ispconfig-3-1/
    .
    Post install I see an apache error:
    Code:
    ‚óŹ
    apache2.service - The Apache HTTP Server
    
       Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
    
       Active: failed (Result: exit-code) since Mon 2020-05-11 01:24:27 IST; 40s ago
    
        Docs: https://httpd.apache.org/docs/2.4/
    
      Process: 9028 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
    
    
    May 11 01:24:27 myhost systemd[1]: Starting The Apache HTTP Server...
    
    May 11 01:24:27 myhost apachectl[9028]: AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.
    
    May 11 01:24:27 myhost apachectl[9028]: AH00526: Syntax error on line 6 of /etc/apache2/sites-enabled/000-ispconfig.vhost:
    
    May 11 01:24:27 myhost apachectl[9028]: Port must be specified
    
    May 11 01:24:27 myhost apachectl[9028]: Action 'start' failed.
    
    May 11 01:24:27 myhost apachectl[9028]: The Apache error log may have more information.
    
    May 11 01:24:27 myhost systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
    
    May 11 01:24:27 myhost systemd[1]: apache2.service: Failed with result 'exit-code'.
    
    May 11 01:24:27 myhost systemd[1]: Failed to start The Apache HTTP Server.
    
    Checking the file I see strange characters in the file
    Code:
    ######################################################
    
    # This virtual host contains the configuration
    
    # for the ISPConfig controlpanel
    
    ######################################################
    
    
     Listen ^A
    
    NameVirtualHost *:^A
    
    
    <VirtualHost _default_:^A>
    
      ServerAdmin [email protected]
    
    
      <Directory /var/www/ispconfig/>
    
        <FilesMatch "\.ph(p3?|tml)$">
    
          SetHandler None
    
        </FilesMatch>
    
      </Directory>
    
      <Directory /usr/local/ispconfig/interface/web/>
    
        <FilesMatch "\.ph(p3?|tml)$">
    
          SetHandler None
    
        </FilesMatch>
    
      </Directory>
    
    
      <IfModule mod_fcgid.c>
    
        DocumentRoot /var/www/ispconfig/
    
        SuexecUserGroup ispconfig ispconfig
    
        <Directory /var/www/ispconfig/>
    
          Options -Indexes +FollowSymLinks +MultiViews +ExecCGI
    
          AllowOverride AuthConfig Indexes Limit Options FileInfo
    
          <FilesMatch "\.php$">
    
            SetHandler fcgid-script
    
          </FilesMatch>
    
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    
                Require all granted
    
              </Directory>
    
        IPCCommTimeout  7200
    
        MaxRequestLen 15728640
    
      </IfModule>
    
    From the looks, the listen part should have a port there. I tried to use 8080, next to listen and in the VirtualHost line, and it worked.
    How to file this bug ?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no nug here, juts a user error. You did not enter a port number when the installer asked you to enter the port number. Instead of entering a port, you entered "^A".

    Replace "^A" with 8080 in all places in the ispconfig vhost file and then restart apache.
     
  3. anandx

    anandx Member HowtoForge Supporter

    Ok got it. I already figured out by replacing the port in the config. I wasn't sure how it had happened. Thanks for clearing it up.
     

Share This Page