New installation errors

Discussion in 'Installation/Configuration' started by IzaKamakazi, Jan 11, 2010.

  1. IzaKamakazi

    IzaKamakazi New Member

    Hi Guys, I have recently installed Ispconfig3 on an Ubuntu 9.10 server whilst following the guide perfect-server-ubuntu-9.10-ispconfig-3.

    I can access the Ispconfig webpage so I continued to setting up 2 websites ( and ).

    I am hosting from home on one IP address.

    I have set the nameservers with UKreg as below.

    Izabay: and
    lookylooky: and

    First off, I can only access my webpages when browsing from the host machine (server). If I try and access from my PC it does not connect.

    From the server I can also access Ispconfig from but cannot access from my PC. Port 80 has been forwarded to the server from the router.

    Secondly, when accessing or from the server I get to the same web page. I uploaded a temporary webpage to /var/www/ and it is home for both addresses.

    I have spent 2 days trying to figure this out but until now I have failed.

    Any suggestions would be appreciated.

    Thanks in advance Kam.
  2. itsnedkeren

    itsnedkeren New Member

    Are you running a DNS server on the machine or using 3rd party?

    If using 3rd party, just make an A Host entry from www.domain.tld to your external Ip-address. Don't forget the MX entry if you need mail on the domains.

    The PC you're using is that on the same router / connection as the server?

    If so, then you won't be able to see the site with it's web address, as most routers don't understand a request coming from within, going to a server the same place.

    I for one, can access your sites fine, ALSO the ISPConfig interface.

    Hope it helps.
  3. IzaKamakazi

    IzaKamakazi New Member

    Hi itsnedkeren,

    Thanks for the speedy reply.

    As part of the server installation tut it installed myDNS package.

    I am using both PC's connected to a Belkin router, so although the websites are working I will never be able to connect to them using my PC?, is there any way around this issue?.

    Thanks for letting me know that the sites are up and running. Do you get the same webpage for both address's?.If so, do you know what i need to do to get the sites pointing to their default folders?.

    Once again thanks for the help.

  4. itsnedkeren

    itsnedkeren New Member

    Have you tried setting your server as DMZ in the belkin router?

    Check if there is a firewall layer between DMZ and local-lan, if so, sort the relevant access.

    Yes you installed MyDNS, but are you actually using it? Have you set up SOA-zones and so on? I've never used the DNS feature of ISPC. I use a 3rd party DNS provider.

    And yes it's the same site for both address, it gives me a directory listing.

    EDIT: Might be an idea to ring Belkin support, if the above doesn't work.
  5. IzaKamakazi

    IzaKamakazi New Member

    Hi, Yes, the server is set as DMZ. I have tried it both ways with no luck.

    Sorry for being vague, I used Ispconfig to setup the records etc and checking with DNS checking websites all show ok.


  6. IzaKamakazi

    IzaKamakazi New Member

    For anyone having problems where as you cannot access your locally hosted webserver by using I can access the webpage by using the internal address I.E 192....

    My router is a Belkin 8235-4 v2 , I have set the webserver a DMZ and forwarded the relevant ports. nothing seemed to work.

    I finally contacted Belkin and this is their solution, which worked on my machine.

    "Well, you can do so by associating the name to the local IP address in the hosts file (a file called hosts with no extension). This file lists IP addresses and host names and is used before actual DNS lookups are done. You can add lines to the hosts file using a text editor like Notepad on Windows. The lines look like: # comment

    The lines contain an IP address and one or more host names separated by white space. Anything that follows a hash sign is a comment and will be ignored. You will need to change the hosts file on all machines in the LAN that need access to the server.

    On Windows, the hosts file can be found in C:\Windows\System32\Drivers\Etc on Windows XP, Vista and Windows 7, in C:\WinNT\System32\Drivers\Etc on Windows 2000, and in C:\Windows on Windows 98 and ME. You need to have administrator rights to edit the file; on Windows Vista and Windows 7 you need to run Notepad as administrator."

    Hopes this helps anyone having similar issues.


    I will now start a fresh post to address my other issues mentioned earlier in this post.
  7. IzaKamakazi

    IzaKamakazi New Member

    deleted as it is a double post. sorry.
    Last edited: Jan 14, 2010

Share This Page