New install Jessie - Issue with Quota

Discussion in 'Installation/Configuration' started by ChuckSC, Oct 3, 2015.

  1. ChuckSC

    ChuckSC New Member

    Hello everyone,

    I have been happily using ISPConfig for a few years on Debian 7 and I am now working on transitioning to Debian 8. I am reinstalling from scratch for a "fresh start" based on the following documentation:

    My VPS: Debian 8 64 bits (HVM)
    Linux version 3.12.46-guest-39-a97a54c-x86_64 ([email protected]) (gcc version 4.9.2 (Debian 4.9.2-10) ) #4 SMP Mon Aug 10 11:59:25 UTC 2015

    I am having some trouble when reaching step "14 Install PureFTPd And Quota" with quotacheck:
    [email protected]:~# nano /etc/fstab
    [email protected]:~# mount -o remount /
    [email protected]:~# quotacheck -avugm
    quotacheck: Cannot stat() mounted device /dev/root: No such file or directory
    quotacheck: Cannot find filesystem to check or filesystem not mounted with quota option.
    [email protected]:~# quotaon -avug
    quotaon: Cannot stat() mounted device /dev/root: No such file or directory
    [email protected]:~# cat /etc/fstab
    /dev/xvda1    /                 ext3    rw,noatime,errors=remount-ro,usrjquota=quota.user,,jqfmt=vfsv0  0    1
    devpts        /dev/pts          devpts  defaults      0 0
    none          /proc             proc    rw,nosuid,noexec  0    0
    I am not sure what the issue is here, maybe it's linked to the way the disks are mounted on the server?
    Even though it doesn't make much sense, I tried creating a symlink but it did not help as /dev/xvda1 is not missing as far as I can tell.
    I also rebooted the server and checked the version:
    • Quota utilities version 4.01.
    After checking the forums for similar issues and exhausting a couple of solutions, I am still unable to complete this step. I welcome any advice on this issue so I can finish my installation properly.

    Thank you.
    Curtis Droppelman likes this.
  2. mattheoh

    mattheoh New Member

    It's because you are on virtual machine I guess... see this screenshot
  3. ChuckSC

    ChuckSC New Member

    Thank you, mattheoh. Sorry for the late answer, I finally had some time to continue with my install.

    When I was in the process of following the install instructions, the file /etc/fstab was not empty. However, it did not look like the one presented in the documentation. I added ",usrjquota=quota.user,,jqfmt=vfsv0" but the rest was already there.

    Since I continued the install despite the message, I can now clearly see the quotas are not working as expected:

    Any advice on what I can do to troubleshoot this and possibly correct the problem? Thanks a lot!
    Curtis Droppelman likes this.
  4. Curtis Droppelman

    Curtis Droppelman New Member

    I recently did a clean install with and this was the only issue I couldn't fix "out of the box" from their tutorial. However, the following steps worked for me:
    ln -s /dev/xvda /dev/root
    ln -s /dev/sda /dev/root
    depending upon on what type of virtualization you have
    2.) This step recreates the symbolic link on reboot
    nano /etc/rc.local
    paste either of the two lines above exit 0 in /etc/rc.local:
    ln -s /dev/xvda /dev/root
    /etc/init.d/quota restart
    ln -s /dev/sda /dev/root
    /etc/init.d/quota restart
    depending upon on what type of virtualization you have (tested working with jessie image)
    sudo reboot
    Quota and Quotacheck work successfully for Debian Jessie.
    Last edited: Apr 18, 2016
    till likes this.

Share This Page