New install, clients directory other place?

Discussion in 'General' started by edge, Sep 23, 2010.

  1. edge

    edge Active Member Moderator

    Not sure if I made a misstake with installing ISPconfig3 or that it's supposed to be like this.

    At the moment I'm moving some websites over from an old ISP 3 server to a new ISP 3 server.

    For some reason some sites (that are making use of fixed paths) did not work, and after a close look I discovered that the client(s) paths are not the same of both servers.

    Old server setup with ISPconfig 3: /var/clients/clientX
    And: /var/www with simlinks to /var/clients/clientX

    New fresh setup with ISPconfig 3: NO /var/clients/clientX
    BUT: /var/www/clients/clientX
    And: /var/www/ with simlinks to /var/www/clients/clientX

    Did I make a mistake when installing ISPconfig 3, or is this the new layout?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats the new layout. The old one caused sometimes problems with suexec as /var/clients is not within the suxec dir that is statically compiled into apache.
     
  3. edge

    edge Active Member Moderator

    clients web directory with /bin /dev /etc ....??

    An other thing that I noted is that the clients web directory has also a lot of other directorys in it (like /bin /dev /etc /home .. see image). Is this also a new thing?

    [​IMG]
     
  4. Hans

    Hans Moderator ISPConfig Developer

    @Edge,
    these directory structure is there because you enablec "jailed" (chrooted) for the website.
     
  5. edge

    edge Active Member Moderator

    Thats the thing. I did not enable "jailed" , and it's only with some sites.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You must have selected jailed either for a ssh user or for a cronjob. Otherwise these directories would have not been created.
     
    Last edited: Sep 27, 2010
  7. edge

    edge Active Member Moderator

    Yes. I did create cronjobs for the accounts. I guess that this set the 'jailed' option to on.

    Thank you for explaining.
     

Share This Page