New Install - Blank page

Discussion in 'Installation/Configuration' started by dkearns, Nov 25, 2011.

  1. dkearns

    dkearns New Member

    Hi everyone.

    New to ISPConfig so forgiveme . I have followed the guide for installing, created a fresh box and installed right from a blank drive.

    Followed this guide (http://www.faqforge.com/category/linux/controlpanels/ispconfig3/)

    All seemed to go very well, no errors or deviations from the guide.

    Got the very final step, of logging into the ispconfig panel and I just get a blank page, no login or anything.

    links / versions etc are from the guide as this was a dry run install to test the software.

    Any ideas ?

    Thanks
    Dan
     
  2. till

    till Super Moderator

    Which tutorial did you use? The link above are no ispconfig installation instructions.
     
  3. dkearns

    dkearns New Member

  4. till

    till Super Moderator

    Ok. Do you get any errors in the apache error log file in /var/log/apache2/ ?
     
  5. dkearns

    dkearns New Member

    Didn't see anything glaringly obvious..

    here's a tail:

    [Fri Nov 25 14:53:54 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Nov 25 14:53:54 2011] [notice] Apache/2.2.20 (Ubuntu) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6-13ubuntu3.2 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.20 OpenSSL/1.0.0e configured -- resuming normal operations
    [Fri Nov 25 14:53:54 2011] [warn] long lost child came home! (pid 18207)
    [Fri Nov 25 14:54:26 2011] [notice] caught SIGTERM, shutting down
    [Fri Nov 25 14:54:27 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Nov 25 14:54:27 2011] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Fri Nov 25 14:54:27 2011] [notice] Digest: generating secret for digest authentication ...
    [Fri Nov 25 14:54:27 2011] [notice] Digest: done
    [Fri Nov 25 14:54:28 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Fri Nov 25 14:54:28 2011] [notice] Apache/2.2.20 (Ubuntu) DAV/2 mod_fcgid/2.3.6 PHP/5.3.6-13ubuntu3.2 with Suhosin-Patch mod_ruby/1.2.6 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.20 OpenSSL/1.0.0e configured -- resuming normal operations

    the page presented at ip:8080 is visually blank and source is just basic
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
    <BODY></BODY></HTML>

    thanks for the (amazingly) speedy replies
     
  6. till

    till Super Moderator

    This html page is not from ispconfig. So you must have either acessed the wrong server (e.g. if you used the hostname and that does not point to the IP yet) from your browser or another software is running on port 8080 that delivered this page.

    Try to access the server by IP address if you used the hostname and post the output of the command:

    netstat -tap
     
  7. dkearns

    dkearns New Member

    systemadmin@khviii:~$ sudo netstat -tap
    [sudo] password for systemadmin:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:10024 *:* LISTEN 17374/amavisd (mast
    tcp 0 0 localhost:10025 *:* LISTEN 17278/master
    tcp 0 0 *:mysql *:* LISTEN 17032/mysqld
    tcp 0 0 *:http-alt *:* LISTEN 18430/apache2
    tcp 0 0 *:www *:* LISTEN 18430/apache2
    tcp 0 0 *:tproxy *:* LISTEN 18430/apache2
    tcp 0 0 khviii.info:domain *:* LISTEN 18243/named
    tcp 0 0 localhost:domain *:* LISTEN 18243/named
    tcp 0 0 *:ftp *:* LISTEN 18224/pure-ftpd (SE
    tcp 0 0 *:ssh *:* LISTEN 634/sshd
    tcp 0 0 localhost:953 *:* LISTEN 18243/named
    tcp 0 0 *:smtp *:* LISTEN 17278/master
    tcp 0 0 *:https *:* LISTEN 18430/apache2
    tcp 0 1 khviii.info:41149 ftp.heanet.ie:www SYN_SENT 26463/freshclam
    tcp 0 52 khviii.info:ssh 172.16.8.55:56378 ESTABLISHED 980/sshd: systemadm
    tcp6 0 0 [::]:pop3s [::]:* LISTEN 18174/couriertcpd
    tcp6 0 0 [::]:pop3 [::]:* LISTEN 18157/couriertcpd
    tcp6 0 0 [::]:imap2 [::]:* LISTEN 18129/couriertcpd
    tcp6 0 0 [::]:domain [::]:* LISTEN 18243/named
    tcp6 0 0 [::]:ftp [::]:* LISTEN 18224/pure-ftpd (SE
    tcp6 0 0 [::]:ssh [::]:* LISTEN 634/sshd
    tcp6 0 0 ip6-localhost:953 [::]:* LISTEN 18243/named
    tcp6 0 0 [::]:imaps [::]:* LISTEN 18146/couriertcpd



    if i goto the IP address of the machine i get the squirrelmail login page, it's only when i goto :8080 do i get that page.

    im suspecting something in my apache config. if i goto :8080 i get the blank page, infact, i can put anything on the :8080 and get the same result. ie
    :8080/index.htm
    :8080/index.php
    :8080/fake

    all redirect me to this mysterious page.

    thanks again
     
  8. till

    till Super Moderator

    That looks ok so far. Please try a different port for ispconfig. Edit the file /etc/apache2/sites-available/ispconfig.vhost:

    vi /etc/apache2/sites-available/ispconfig.vhost

    and replace all occurrences of 8080 with e.g. 8888

    Then restart apache with:

    /etc/init.d/apache2 restart

    and try to reach the controlpanel on port 8888
     
  9. dkearns

    dkearns New Member

    Hiya,

    Replaced them with 8888 and restarted.

    My blank page has moved to 8888 now, and 8080 gives me page cannot be displayed.
     
  10. till

    till Super Moderator

    Please post the content of the ispconfig vhost file.
     
  11. dkearns

    dkearns New Member

    Code:
    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################
    
     Listen 8888
    NameVirtualHost *:8888
    
    <VirtualHost _default_:8888>
      ServerAdmin webmaster@localhost
    
      <IfModule mod_fcgid.c>
        DocumentRoot /var/www/ispconfig/
        SuexecUserGroup ispconfig ispconfig
        <Directory /var/www/ispconfig/>
          Options Indexes FollowSymLinks MultiViews +ExecCGI
          AllowOverride AuthConfig Indexes Limit Options FileInfo
          AddHandler fcgid-script .php
          FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
          Order allow,deny
          Allow from all
        </Directory>
      </IfModule>
    
      <IfModule mod_php5.c>
        DocumentRoot /usr/local/ispconfig/interface/web/
        AddType application/x-httpd-php .php
        <Directory /usr/local/ispconfig/interface/web>
          Options FollowSymLinks
          AllowOverride None
          Order allow,deny
          Allow from all
              php_value magic_quotes_gpc        0
        </Directory>
      </IfModule>
    
      # ErrorLog /var/log/apache2/error.log
      # CustomLog /var/log/apache2/access.log combined
      ServerSignature Off
    
    
      <IfModule mod_security2.c>
        SecRuleEngine Off
      </IfModule>
    
      # SSL Configuration
      SSLEngine On
      SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
      SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    
    </VirtualHost>
    
    <Directory /var/www/php-cgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
    <Directory /var/www/php-fcgi-scripts>
        AllowOverride None
        Order Deny,Allow
        Deny from all
    </Directory>
    
     
  12. dkearns

    dkearns New Member

    Good morning,

    Ive just realised that the server/phpmyadmin link is working, which was set up in the /conf.d folder

    Think this would be apache related then?

    Thanks
     
  13. falko

    falko Super Moderator

    On port 8888?

    Is this a stock ISPConfig, or did you modify its sources?

    Could it be a firewall issue?
     
  14. lifeisboost

    lifeisboost New Member

    I just did an install on a dev server and ran into this issue. Try connecting with https as you can see in
    /etc/apache2/sites-available/ispconfig.vhost

    it has SSL engine on. I could not connect to it on http but as soon as i typed in https i connected fine.
     
    Last edited: Nov 30, 2011

Share This Page