New Email-Account: Bouncing address shows [email protected]

Discussion in 'Installation/Configuration' started by AceLine, Sep 14, 2016.

  1. AceLine

    AceLine New Member

    Hi Till, hi Falco, hi Forumianers,
    first let me tell you my versions:
    ##### ISPCONFIG #####
    ISPConfig version is 3.0.5.4p9
    ##### VERSION CHECK #####
    [INFO] php (cli) version is 5.6.20-0+deb8u1
    [INFO] php-cgi (used for cgi php in default vhost!) is version 5.6.20-0+deb8u1
    My problem is as follows:
    I go to tab Email -> Email Mailbox -> Add new Mailbox and there fill all fields as needed:
    1.) Name: Example Name
    2.) Email: [email protected]
    3.) Login: xyz-username (I configured Main Config -> Allow custom login name: yes)
    4.) Password: aVerySecurePassword
    Everything works great, but one thing. All emails sent by this account through Roundcube get automatically this header entry:
    From: xyz-username <[email protected]>
    Please give me an idea what is wrong with my configuration and how can I fix this problem...

    Best regards and again thanx for your great work!
    Ingmar
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the RoundCube account settings (in RoundCube), there must be an option somewhere where you can set the sender address for the account in RoundCube.
     
  3. AceLine

    AceLine New Member

    Thank you for your fast reply. If it was only for myself, this would be the solution. But I'm maintaining three servers for some companies with lots of users. I can not force all of them to first edit the Roundcube settings, before they are able to send emails to gmx, gmail & Co. without getting blocked as spam.
    Is there a way to configure Roundcobe within ISPC 3 to automatically use the account owners email address for the headers From: entry?

    Thanx again for your help...

    Ingmar
     
  4. webguyz

    webguyz Member HowtoForge Supporter

    Take a look at the options in config/config.inc.php:

    $config['smtp_server'] = 'tls://%h';
    // SMTP port (default is 25; use 587 for STARTTLS or 465 for the
    // deprecated SSL over SMTP (aka SMTPS))
    $config['smtp_port'] = 587;
    // SMTP username (if required) if you use %u as the username Roundcube
    // will use the current username for login
    $config['smtp_user'] = '%u';
    // SMTP password (if required) if you use %p as the password Roundcube
    // will use the current user's password for login
    $config['smtp_pass'] = '%p';
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This would happen if you had used the ispconfig default (username = email address), by using a custom username, RoundCube can not know to which domain the username belongs to and what the email address for this username is, therefore it has to user [email protected] when the account is used the first time.
     

Share This Page