New domains not added to Bind9 DNS

Discussion in 'Installation/Configuration' started by DKLeader, Jan 13, 2011.

  1. DKLeader

    DKLeader New Member

    Hi,

    System has been running well untill today.
    Runnning all servers on Debian Lenny.
    All servers are physical servers.
    ISPConfig vers : 3.0.3.2

    Problem : When I now add a new dns zone in ISPConfig they are not added to named.conf.local or as a pri.[domain] to /etc/bind. I dont get any errors during the creation of the dns zone.

    My dns servers : (they are behind a firewall)
    ns1.superweb.dk (92.62.196.66 - 192.168.100.66)
    ns2.superweb.dk (92.62.196.67 - 192.168.100.67)
    ns3.superweb.dk (92.62.196.77 - 192.168.100.77)
    port 53 is opened (TCP and UDP)

    ISPConfig is on 92.62.196.69 - 192.168.1.90 (behind another firewall)

    What I have tried :
    On ns1 :
    Code:
    netstat -tap
    result :
    Code:
    ns1:/etc/bind# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:tcpmux                *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:20034                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:32771                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:32772                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:40421                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:32773                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:32774                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:38311                 *:*                     LISTEN      2214/rpc.statd
    tcp        0      0 *:8009                  *:*                     LISTEN      3387/jsvc
    tcp        0      0 *:31337                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:rsync                 *:*                     LISTEN      3087/rsync
    tcp        0      0 192.168.100.66:mysql    *:*                     LISTEN      15268/mysqld
    tcp        0      0 *:ircd                  *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:systat                *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:netbios-ssn           *:*                     LISTEN      3129/smbd
    tcp        0      0 *:5900                  *:*                     LISTEN      3645/vino-server
    tcp        0      0 *:5742                  *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:1935                  *:*                     LISTEN      3083/java
    tcp        0      0 *:50959                 *:*                     LISTEN      3083/java
    tcp        0      0 *:9999                  *:*                     LISTEN      3083/java
    tcp        0      0 *:finger                *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:netstat               *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:imap2                 *:*                     LISTEN      3168/xinetd
    tcp        0      0 *:sunrpc                *:*                     LISTEN      2203/portmap
    tcp        0      0 *:54320                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:cisco-sccp            *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:www                   *:*                     LISTEN      3407/apache2
    tcp        0      0 *:27665                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:8180                  *:*                     LISTEN      3387/jsvc
    tcp        0      0 *:ingreslock            *:*                     LISTEN      3426/portsentry
    tcp        0      0 192.168.100.66:domain   *:*                     LISTEN      20899/named
    tcp        0      0 localhost:domain        *:*                     LISTEN      20899/named
    tcp        0      0 *:51413                 *:*                     LISTEN      19900/transmission
    tcp        0      0 *:ftp                   *:*                     LISTEN      3152/vsftpd
    tcp        0      0 *:ssh                   *:*                     LISTEN      2671/sshd
    tcp        0      0 *:nntp                  *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:5080                  *:*                     LISTEN      3083/java
    tcp        0      0 *:omniorb               *:*                     LISTEN      3083/java
    tcp        0      0 *:socks                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 localhost:953           *:*                     LISTEN      20899/named
    tcp        0      0 *:12345                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:smtp                  *:*                     LISTEN      3071/master
    tcp        0      0 192.168.100.66:21370    *:*                     LISTEN      21775/vsftpd
    tcp        0      0 *:12346                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:8443                  *:*                     LISTEN      3083/java
    tcp        0      0 *:635                   *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:49724                 *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:uucp                  *:*                     LISTEN      3426/portsentry
    tcp        0      0 *:microsoft-ds          *:*                     LISTEN      3129/smbd
    tcp     3875      0 192.168.100.66:48537    dedi112.xirvik.co:40623 ESTABLISHED 19900/transmission
    tcp        0      9 192.168.100.66:51413    80.71.135.43:35588      ESTABLISHED 19900/transmission
    tcp        0      0 192.168.100.66:51413    x1-6-00-26-f2-d4-:52654 ESTABLISHED 19900/transmission
    tcp        0  34801 192.168.100.66:51413    77.68.168.104:63441     ESTABLISHED 19900/transmission
    tcp        0      0 192.168.100.66:46239    89.184.146:font-service ESTABLISHED 19900/transmission
    tcp        0      0 192.168.100.66:51413    217.142.135.200:3955    ESTABLISHED 19900/transmission
    ^C
    ns1:/etc/bind#
    
    My named.conf :
    Code:
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the
    // structure of BIND configuration files in Debian, *BEFORE* you customize
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    // include "/etc/bind/named.conf.options";
    options {
            directory "/var/cache/bind";
            recursion yes;
            allow-query { "any"; };
            allow-recursion { "any"; };
            allow-transfer { "any"; };
            query-source address * port 53;
            dnssec-enable yes;
            dnssec-validation yes;
            forward first;
            forwarders {
                    89.221.173.178;
                    89.221.173.182;
                    193.163.102.6;
            };
    
            auth-nxdomain no;    # conform to RFC1035
            listen-on-v6 { any; };
            listen-on { any; };
    };
    // # Use with the following in named.conf, adjusting the allow list as needed:
    key "rndc-key" {
            algorithm hmac-md5;
            secret "something";
    };
    
    controls {
            inet 127.0.0.1 port 953
                    allow { 127.0.0.1; } keys { "rndc-key"; };
    };
    
    // prime the server with knowledge of the root servers
    zone "." {
            type hint;
            file "/etc/bind/db.root";
    };
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    zone "localhost" {
            type master;
            file "/etc/bind/db.local";
    };
    zone "127.in-addr.arpa" {
            type master;
            file "/etc/bind/db.127";
    };
    zone "0.in-addr.arpa" {
            type master;
            file "/etc/bind/db.0";
    };
    zone "255.in-addr.arpa" {
            type master;
            file "/etc/bind/db.255";
    };
    include "/etc/bind/named.conf.local";
    
    Doing a status on bind gives that it is running and no error.
    Tried
    Code:
    named -d9 -g -c /etc/bind/named.conf
    and couldnt see any errors in that part.

    From syslog :
    Code:
    Jan 13 16:19:52 ns1 named[20899]: starting BIND 9.6-ESV-R3 -u bind
    Jan 13 16:19:52 ns1 named[20899]: built with '--prefix=/usr' '--build=i486-linux-gnu' '--host=i486-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--$
    Jan 13 16:19:52 ns1 named[20899]: adjusted limit on open files from 1024 to 1048576
    Jan 13 16:19:52 ns1 named[20899]: found 4 CPUs, using 4 worker threads
    Jan 13 16:19:52 ns1 named[20899]: using up to 4096 sockets
    Jan 13 16:19:52 ns1 named[20899]: loading configuration from '/etc/bind/named.conf'
    Jan 13 16:19:52 ns1 named[20899]: using default UDP/IPv4 port range: [1024, 65535]
    Jan 13 16:19:52 ns1 named[20899]: using default UDP/IPv6 port range: [1024, 65535]
    Jan 13 16:19:52 ns1 named[20899]: no IPv6 interfaces found
    Jan 13 16:19:52 ns1 named[20899]: listening on IPv4 interface lo, 127.0.0.1#53
    Jan 13 16:19:52 ns1 named[20899]: listening on IPv4 interface eth0, 192.168.100.66#53
    Jan 13 16:19:52 ns1 named[20899]: /etc/bind/named.conf:15: using specific query-source port suppresses port randomization and can be insecure.
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 254.169.IN-ADDR.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: D.F.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 8.E.F.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: 9.E.F.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: A.E.F.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: automatic empty zone: B.E.F.IP6.ARPA
    Jan 13 16:19:52 ns1 named[20899]: command channel listening on 127.0.0.1#953
    Jan 13 16:19:52 ns1 named[20899]: zone 0.in-addr.arpa/IN: loaded serial 1
    Jan 13 16:19:52 ns1 named[20899]: zone 127.in-addr.arpa/IN: loaded serial 1
    Jan 13 16:19:53 ns1 named[20899]: zone 255.in-addr.arpa/IN: loaded serial 1
    Jan 13 16:19:53 ns1 named[20899]: zone 24-timerssejlads.dk/IN: loaded serial 2011011102
    Jan 13 16:19:53 ns1 named[20899]: zone 24timerssejlads.dk/IN: loaded serial 2010101301
    .
    .
    Jan 13 16:19:53 ns1 named[20899]: zone voice-online.dk/IN: loaded serial 2010100201
    Jan 13 16:19:53 ns1 named[20899]: zone xn--caf13-dsa.dk/IN: loaded serial 2010100201
    Jan 13 16:19:53 ns1 named[20899]: zone localhost/IN: loaded serial 2
    Jan 13 16:19:53 ns1 named[20899]: running
    Jan 13 16:19:53 ns1 named[20899]: zone vinterbil.dk/IN: sending notifies (serial 2010101801)
    .
    .
    Jan 13 16:19:53 ns1 named[20899]: zone superweb.dk/IN: sending notifies (serial 2011011101)
    Jan 13 16:19:53 ns1 named[20899]: zone la-krydseren.dk/IN: sending notifies (serial 2010101301)
    Jan 13 16:19:53 ns1 named[20899]: zone phpmyadmin.superweb.dk/IN: sending notifies (serial 2011011101)
    Jan 13 16:20:01 ns1 /USR/SBIN/CRON[20915]: (root) CMD (/usr/local/ispconfig/server/server.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    
    If anyone got a suggestion to what I could have done to suddenly get this problem I would like to hear it :)
     
    Last edited: Jan 13, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if there are any jobs listed in the jobqueue in the ispconfig monitor.
     
  3. DKLeader

    DKLeader New Member

    It says :

    Code:
    2011-01-13 22:57 ns1.superweb.dk Update dns_soa  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_rr  
    2011-01-13 22:56 ns1.superweb.dk Insert dns_soa 
    
    and a few others that I have tried to create / delete since I noticed the problem.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. So your problem is that the jobqueue dont get executed and it is not specific to BIND.

    Please enable loglevel debug under system > server config and then run this command as root on the shell and post the output:

    /usr/local/ispconfig/server/server.sh
     
  5. DKLeader

    DKLeader New Member

    If I run it on the web / cp server I get :
    Code:
    web:~# /usr/local/ispconfig/server/server.sh
    14.01.2011-11:41 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig                                               _lock
    14.01.2011-11:41 - DEBUG - No Updated records found, starting only the core.
    14.01.2011-11:41 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispcon                                               fig_lock
    finished.
    web:~#
    
    and on ns1 :
    Code:
    ns1:/# /usr/local/ispconfig/server/server.sh
    /etc/profile: line 25: unmask: command not found
    
    Warning: mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 111 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    
    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    
    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    
    Warning: mysql_connect(): Lost connection to MySQL server at 'reading initial communication packet', system error: 111 in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78
    
    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    
    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    finished.
    ns1:/#
    
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if your slave server is not able to connect to the master database. As you updated to ispconfig 3.0.3.2, have you choosen to reconfigure master database permissions as you updated the master or the slave?
     
  7. DKLeader

    DKLeader New Member

    Not that I recall.
     
  8. DKLeader

    DKLeader New Member

    Just tried on my ns2 server and got :
    Code:
    ns2:~# /usr/local/ispconfig/server/server.sh
    
    Warning: mysql_connect(): Lost connection to MySQL server at 'reading initial co                                                                                        mmunication packet', system error: 111 in /usr/local/ispconfig/server/lib/classe                                                                                        s/db_mysql.inc.php on line 78
    
    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in                                                                                         /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    
    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in                                                                                         /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    
    Warning: mysql_connect(): Lost connection to MySQL server at 'reading initial co                                                                                        mmunication packet', system error: 111 in /usr/local/ispconfig/server/lib/classe                                                                                        s/db_mysql.inc.php on line 78
    
    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in                                                                                         /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63
    
    Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in                                                                                         /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64
    finished.
    ns2:~#
     
    Last edited: Jan 14, 2011
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please redo the update on the master server by following these steps:

    Code:
    cd /tmp
    wget [url]http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz[/url]
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Select yes when the updater asks you "Reconfigure Permissions in master database?". Then wait a few minutes and check again the jobqueue in the master if it gets emptied.
     
  10. DKLeader

    DKLeader New Member

    Tried your suggestion before lunch - have just checked when I got back and it is stlll the same with the jobqueue .

    Tried
    Code:
    /usr/local/ispconfig/server/server.sh
    on ns1 and ns2 and I am still getting the same errors.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Then try the same update on one of the slaves with "Reconfigure Permissions in master database?" = yes.
     
  12. DKLeader

    DKLeader New Member

    This is getting more and more strange.

    Tried to run the same on one of the remotes and got :
    Code:
    Unable to connect to mysql server Lost connection to MySQL server at 'reading initial communication packet', system error: 111
    
    If I connect to mysql from phpmyadmin - no problem, even using remote connection - got phpmyadmin on one site.

    Then I tried
    Code:
    mysql -h db9.superweb.dk -P 3308 -u root -p
    on the master (master is db9.superweb.dk / 92.62.196.69) and no problems conneting. Router is set to external port 3308 - internal port 3306
    Tried the same from one of the other servers and got :
    Code:
    ERROR 2003 (HY000): Can't connect to MySQL server on '92.62.196.69' (111)
    In my my.inf :
    Code:
    [client]
    port            = 3308
    socket          = /var/run/mysqld/mysqld.sock
    
    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram
    
    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket          = /var/run/mysqld/mysqld.sock
    nice            = 0
    
    [mysqld]
    #
    # * Basic Settings
    #
    user            = mysql
    pid-file        = /var/run/mysqld/mysqld.pid
    socket          = /var/run/mysqld/mysqld.sock
    port            = 3308
    basedir         = /usr
    datadir         = /var/lib/mysql
    tmpdir          = /tmp
    
    tried with 3306 and a restart but still the same, exept that ispconfig works, but then phpmyadmin doesnt.

    Finally did a ps :
    Code:
    web:/var/log/mysql# ps -efH | grep mysql
    root     21985 14541  0 14:13 pts/1    00:00:00         grep mysql
    root     21494     1  0 13:56 pts/1    00:00:00   /bin/sh /usr/bin/mysqld_safe
    mysql    21531 21494  0 13:56 pts/1    00:00:00     /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3308 --socket=/var/run/mysqld/mysqld.sock
    root     21532 21494  0 13:56 pts/1    00:00:00     logger -p daemon.err -t mysqld_safe -i -t mysqld
    web:/var/log/mysql#
    
    I am still lost and have lost ftp connection to the domains also.
     
    Last edited: Jan 14, 2011
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe mysql on the master blocks connections because there were too many false logins. Try to issue this command on the master and then chack the jobqueue a few minutes later:

    mysqladmin -u root -p flush-hosts
     
  14. CSsab

    CSsab New Member

    This is a stab in the dark but may be part of the problem here. On a fresh install of ISPConfig I get the following errors:

    PHP Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 78

    Line 78:
    $this->linkId = mysql_connect($this->dbHost, $this->dbUser, $this->dbPass);


    PHP Warning: mysql_errno() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 63

    Line 63: $this->errorNumber = mysql_errno($this->linkId);

    PHP Warning: mysql_error() expects parameter 1 to be resource, boolean given in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 64

    Line 64: $this->errorMessage = mysql_error($this->linkId);


    ..
    ..
    ..

    sh: mailq: command not found
    sh: mailq: command not found
    sh: mailq: command not found (NOTE: don't have mail server installed on this which is the host)

    ...
    ...
    ...

    /usr/local/ispconfig/server/server.sh: line 7: 8182 Segmentation fault /usr/bin/php -q /usr/local/ispconfig/server/server.php

    Line 7 /usr/bin/php -q /usr/local/ispconfig/server/server.php

    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory

    ...
    ...
    ...

    /bin/sh: /usr/local/ispconfig/server/cron_daily.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory
    /bin/sh: /usr/local/ispconfig/server/server.sh: No such file or directory

    ...
    ...
    ...

    Hope this helps.
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial (URL) did you use to set up the server?
    Are the MySQL details in /usr/local/ispconfig/interface/lib/config.inc.php correct?
     
  16. DKLeader

    DKLeader New Member

    I have partly slved my problem. It seems to be a port configuration problem.

    I have used this tutorial : http://www.howtoforge.com/installing-a-multiserver-setup-with-dedicated-web-email-dns-and-mysql-database-servers-on-debian-5.0-with-ispconfig-3

    As I have 3 of the servers behind a router and all of them are running mysql (got 9 servers running mysql) and I wanted a shared phpmyadmin. Due to this I used different external ports and 3306 as internal for the ones behind the router.

    If I set my.cnf to the external port I can use the shared phpmyadmin but then ISPConfig fails. I then changed my.cnf to internal port (3306) and then ISPConfig fails, and then I get from phpmyadmin :
    Code:
    #2013 - Lost connection to MySQL server at 'reading initial communication packet', system error: 111
    
    In config.inc.php used for phpmyadmin I have set up for each server as this :
    Code:
    /*
     * Ninth server - 92.62.196.69 - 192.168.1.90
     */
    $i++;
    /* Authentication type */
    $cfg['Servers'][$i]['auth_type'] = 'cookie';
    /* Server parameters */
    $cfg['Servers'][$i]['host'] = 'db9.superweb.dk:3308';
    $cfg['Servers'][$i]['connect_type'] = 'tcp';
    $cfg['Servers'][$i]['compress'] = false;
    /* Select mysqli if your server has it */
    $cfg['Servers'][$i]['extension'] = 'mysql';
    
    /* rajk - for blobstreaming */
    $cfg['Servers'][$i]['bs_garbage_threshold'] = 50;
    $cfg['Servers'][$i]['bs_repository_threshold'] = '32M';
    $cfg['Servers'][$i]['bs_temp_blob_timeout'] = 600;
    $cfg['Servers'][$i]['bs_temp_log_threshold'] = '32M';
    
    On the router 3308 is forwarded to 192.168.1.90 as 3306.

    And in my zone it should be ok :
    Code:
    $TTL        3600
    @       IN      SOA     ns1.superweb.dk. admin.superweb.dk. (
                            2011011401       ; serial, todays date + todays serial #
                            3600              ; refresh, seconds
                            3600              ; retry, seconds
                            1209600              ; expire, seconds
                            3600 )            ; minimum, seconds
    ;
    
    cp.superweb.dk.      A        92.62.196.69
    db1.superweb.dk.      A        92.62.196.66
    db2.superweb.dk.      A        92.62.196.67
    db3.superweb.dk.      A        92.62.196.69
    db4.superweb.dk.      A        92.62.196.69
    db5.superweb.dk.      A        92.62.196.70
    db6.superweb.dk.      A        92.62.196.71
    db7.superweb.dk.      A        92.62.196.72
    db8.superweb.dk.      A        92.62.196.69
    db9.superweb.dk.      A        92.62.196.69
    ftp.superweb.dk.      CNAME        superweb.dk.
    mail.superweb.dk.      A        92.62.196.69
    ns1.superweb.dk.      A        92.62.196.66
    ns2.superweb.dk.      A        92.62.196.67
    ns3.superweb.dk.      A        92.62.196.77
    superweb.dk.      A        92.62.196.69
    superweb.dk.      MX    10   mail.superweb.dk.
    superweb.dk.      MX    15   superweb.dk.
    superweb.dk.      NS        ns1.superweb.dk.
    superweb.dk.      NS        ns2.superweb.dk.
    superweb.dk.      NS        ns3.superweb.dk.
    www.superweb.dk.      CNAME        superweb.dk.
    
    But anyway the ISPConfig is working and at the moment I can live without shared phpmyadmin.
     

Share This Page