New Domain isn't working with my ISPconfig configuration

Discussion in 'Installation/Configuration' started by SaschaBe, Jan 28, 2017.

  1. SaschaBe

    SaschaBe New Member

    Hi,
    I've tried to configure a new domain with an ending of ".gl" with ISPconfig.
    The new domain is always looking on the root html dir (/var/www/html/) not at the redirected dir (var/www/somedomain.gl/web)
    The apache sites-enabled configuration looks like this:
    Code:
    # Apache did not start after modifying this vhost file.
    # Please check file /etc/apache2/sites-available/satix.gl.vhost.err for syntax errors.
    
    I've checked the sites-available configuration and didn't saw any syntax errors.
    Other domains with the ending i.e. .de, .eu working properly with ISPconfig .
    After trying to set the configuration manually, my apache2 don't want to start.
    My System is running with Debian 8 Jessy , ISPconfig 3.1.1p1 and with an Apache2.
    I've set the DNS-Records correct (like the other domains I have at the same hoster).
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's why ISPConfig saved the file with .err ending. The domain name ending .gl is not the problem here, domain endings dont matter for apache, yu can use anything as tld.

    Which error message did you got when you tried to restart apache?
     
  3. SaschaBe

    SaschaBe New Member

    Hi,
    First thanks for your reply and you have to apologize my late answer, but here we go:
    I'll paste alle infos i've got about the error:

    vhost.err:
    Code:
    <Directory /var/www/domain.gl>
                    AllowOverride None
                                    Require all denied
                    </Directory>
    
    <VirtualHost :80>
    
                                                                            DocumentRoot /var/www/domain.gl/web
    
                    ServerName domain.gl
                    ServerAlias www.domain.gl
                    ServerAdmin webmaster@domain.gl
    
                    ErrorLog /var/log/ispconfig/httpd/domain.gl/error.log
    
                    Alias /error/ "/var/www/domain.gl/web/error/"
                    ErrorDocument 400 /error/400.html
                    ErrorDocument 401 /error/401.html
                    ErrorDocument 403 /error/403.html
                    ErrorDocument 404 /error/404.html
                    ErrorDocument 405 /error/405.html
                    ErrorDocument 500 /error/500.html
                    ErrorDocument 502 /error/502.html
                    ErrorDocument 503 /error/503.html
    
                    <IfModule mod_ssl.c>
                    </IfModule>
    
                    <Directory /var/www/domain.gl/web>
                                    # Clear PHP settings of this website
                                    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
                                                    SetHandler None
                                    </FilesMatch>
                                    Options +FollowSymLinks
                                    AllowOverride All
                                                                    Require all granted
                                                                    <Files ~ '.php[s3-6]{0,1}$'>
                                                                                                    Require all denied
                                                                                    </Files>
                    </Directory>
                    <Directory /var/www/clients/client0/web14/web>
                                    # Clear PHP settings of this website
                                    <FilesMatch ".+\.ph(p[345]?|t|tml)$">
                                                    SetHandler None
                                    </FilesMatch>
                                    Options +FollowSymLinks
                                    AllowOverride All
                                                                    Require all granted
                                                                    <Files ~ '.php[s3-6]{0,1}$'>
                                                                                    Require all denied
                                                                            </Files>
                    </Directory>
    
    
    
    
                  
                    # suexec enabled
                    <IfModule mod_suexec.c>
                            SuexecUserGroup web14 client0
                    </IfModule>
    
    
    
                    # add support for apache mpm_itk
                    <IfModule mpm_itk_module>
                            AssignUserId web14 client0
                    </IfModule>
    
                    <IfModule mod_dav_fs.c>
                    # Do not execute PHP files in webdav directory
                            <Directory /var/www/clients/client0/web14/webdav>
                                    <ifModule mod_security2.c>
                                            SecRuleRemoveById 960015
                                            SecRuleRemoveById 960032
                                    </ifModule>
                                    <FilesMatch "\.ph(p3?|tml)$">
                                            SetHandler None
                                    </FilesMatch>
                            </Directory>
                            DavLockDB /var/www/clients/client0/web14/tmp/DavLock
                            # DO NOT REMOVE THE COMMENTS!
                            # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
          # WEBDAV BEGIN
                            # WEBDAV END
                    </IfModule>
    
    
    
    </VirtualHost>
    
    
    Outpot Apache after setting configuration manually:
    apache2.service:
    "bad user name web13": This one existing.
    The error.log doesn't give me any information.

    Actually I don't even get any connection between the DB-User and the DB itselfs.
    I'll think my whole ISpconfig configuration is damaged.
    I've already checked all permissions and files and tried some reconfiguration without any solutions.
    Maybe I'll rollback to an older configuration!?

    Best regards.
     

Share This Page