New databasename ?

Discussion in 'General' started by dspuser, May 28, 2006.

  1. dspuser

    dspuser New Member

    Hi.

    I'm setting up a cms system on my ISPconfig.

    There is an install utility with the cms system.

    Deafaults are:

    The name of the databasehost is "localhost"

    The name of the databaseuser is "fundanemt"
    The name of the database is "fundanemt"

    Can I enter those name in the database and how ?

    I can see, that the deafult names in ISPconfig is of this form:

    web_db1
    web1_u1

    /dspuser
     
  2. sjau

    sjau Local Meanie Moderator

    throught phpMyAdmin you could create a new user but I would rather use the ones supplied by ISPconfig :)
     
  3. dspuser

    dspuser New Member

    Thanks for a fast reply. Now I have tried to use the ones supplied by ISPconfig:

    HTML:
    Welcome to the Fundanemt 2.1 installation
    Please follow these easy steps to get Fundanemt up and running in no time.
    Database informations:
    Database type:
    Database host:localhost
    Database port:
    Database name:web1_db1
    Database user:web1_u1
    Database password:xxxyyyzzz
    Table prefix:
    But I got this message:

    HTML:
    Couldn't connect to database, please contact administrator
     
  4. dspuser

    dspuser New Member

    Database type:MySQL
     
  5. sjau

    sjau Local Meanie Moderator

    Hmmm, are you sure you don't have to entehr the database type?

    Anyway, in order to check whether the actual user supplied by ISPConfig works, use this little script here:

     
  6. dspuser

    dspuser New Member


    Hi.

    I forgot to enter the databasetype in what I sent here.

    How can I change user and password for the database ?
     
  7. dspuser

    dspuser New Member

    I got this running the script:

    Code:
    ./mysql
    ./mysql: line 1: ?: No such file or directory
    ./mysql: line 3: //Global: No such file or directory
    ./mysql: line 4: =: command not found
    ./mysql: line 4: //: is a directory
    ./mysql: line 5: =: command not found
    ./mysql: line 5: //: is a directory
    ./mysql: line 6: =: command not found
    ./mysql: line 6: //: is a directory
    ./mysql: line 7: =: command not found
    ./mysql: line 7: //name: No such file or directory
    ./mysql: line 9: //: is a directory
    ./mysql: line 10: syntax error near unexpected token `"$db_host","$username","$password"'
    ./mysql: line 10: [email protected]_connect("$db_host","$username","$password")'
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The password can be changed withi ISPCOnfig.

    If you want to use another username and password you will have to use phpmyadmin or change it on the commandline with the 'mysql' program.
     
  9. sjau

    sjau Local Meanie Moderator

    the script that I posted is a php script... just create a .php file (e.g. test.php) in your webfolder and call it from the browser :)
     
  10. dspuser

    dspuser New Member


    @till

    Ok thanks. This is via ISP Manager=>ISP site=>Options=>Database Name ?
     
  11. dspuser

    dspuser New Member

    @sjau

    Thanks for this :)
     
  12. dspuser

    dspuser New Member

    I cannot connect to the database.

    I meanwhile is keeping a pause from the work.

    But what port should be used for phpMyAdmin ?
     
  13. falko

    falko Super Moderator ISPConfig Developer

    If you have installed the ISPConfig phpMyAdmin package, it's on port 81, and there's a link to it under "Tools".
    If you've installed phpMyAdmin in one of your web sites, then it's on port 80, of course.

    Can you connect to MySQL on the shell like this?

    Code:
    mysql -u <username> -p
     

Share This Page