Never Actually got It To Work...

Discussion in 'Installation/Configuration' started by jjw, Aug 30, 2006.

  1. jjw

    jjw New Member

    First, I want to thank Falko for the How To and ISPConfig. I am quite sure you've spent a lot of time, energy, and emotion here. I cannot do what you do, and I appreciate the opportunity to try and use this freely shared knowlege of yours.

    I'm sure that I'll get booed for what comes next.

    I've spent 6 days trying to get ISPconfig top work on a brand new fresh install following the perfect hot to for Core 4. The mail deal is broken. Just broken.

    I remove postfix, I remove all certs, remove /etc/postfix, reinstal postfix, rebuild certs per hos to, rebuild postfix main.cf from scratch (per the perfect install). Every time I rebuild (well over 20 times), I get a message that the certificates are invalid (8182), and then I follow the rebuilding. Every time.

    After this, I can send mails to addresses I've created from other domains, I can see them delivered, I can see them forwarded. I can't, however, send mail remotely with an email client (and for the last thre or four installs can't even get mail remotely), which is the only reason I need to install ISP Config. I can handle web no problem, and mail in a LAN environment. I've not been able to get SMTP AUTH to work, ever, and I've tried ISPConfig for this.

    Users cannot log into the https://domain.com:81/mailuser because www.domain.com cannot be found...What? I have no idea why not. I swear to god I am not trying to rant, but looking back, I had to solve mail looping back, I had issues with CTX (no idea), and errors such as:

    451 Server configuration error
    routines:SSL_CTX_use_certificate_chain_file:system lib
    Unable to load certificate from /usr/share/ssl/certs/ipop3d.pem

    I've actually been fired from the job, which isn't surprising: I couldn't deliver. I still want to try and figure this out. Why am I reading about certs that aren't referenced in the perfect setup or ispconfig?

    JJW
     
  2. Rocky

    Rocky New Member

    I'm sorry to hear about you losing your job. However, the Perfect setup has outlined everything, in details, as to how to configure your system. Now, according to which version you choose, that's up to you.

    The requirements are that you have a FQDN.
    You must then have an MX record for that domain.

    If you don't have the proper DNS entries, you will have problems, such as www.domain.com not being found.

    I think in your case, you simply didn't have the proper DNS entries. That would be why you were having so many issues.

    By the way, what's the domain name and what type of internet connectivity did you use for this setup?
     
  3. jjw

    jjw New Member

    Hi Rocky. Thank you for answering.

    We had DNS & MX records pointing to the IP. I built perfectly fine a server that could receive mail, and serve websites. Name service was offsite, and resolved perfectly to our IP. We had several IPS available, one dedicated strictly for the server. What I could not get, and thus tried to get with ISPConfig, was SMTP AUTH, so that *remote* clients could send mail through the server to a domain *not* ours. Never happend.

    I did follow the perfect install for Core 4. Several times. The server was remote to me, and I had to talk a local guy there through the install from DVD several times (after 6 or 7 failed attempts, I figured it was better to start with a clean slate).

    My statement about MX & DNS records where with regard to ISPConfig, and whether or not I needed to enter them there. I've never gotten SMTP AUTH, Never been able to get it to work. I've never come across a primer that guided me to success. This is my fault, no one else's.

    <edit>

    When I say I talked someone through the install, I talked them through the Core 4 base install. Once the server rebooted, I SSHed in and completed the install/config/testing/failure. :)
     
    Last edited: Aug 31, 2006
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Hi JJW,

    we (Falko and I) are making ISPConfig installations every day and the perfect setup guides really work, if you copy the commands line by line and edit the files as described in the howto. I'am sorry to hear that you loosed your job, but why have you not posted your problems earlier to the forums or ordered a ISPConfig remote installation so we could have helped you?

    Without having access to the system it is not easy to say what has gone wrong. Do you have an excrpt of the mail log?
     
  5. jjw

    jjw New Member


    Hi Till,

    I didn't know about this forum until yesterday. I found the guide through internet search but I did not know there was a forum to ask questions of the developers. :)

    You're right of course. It's hard to figure out what went wrong without access to the system and logs. I will attempt setting this up locally with the knowlege that this forum exists, and you can bet I'll ask questions.

    Thanks ,

    JJW
     

Share This Page